2

for the last 6 weeks (yes, that long) I've been struggling to successfully deliver emails to Gmail accounts.

For some reason, every single email that is sent from our domain is flagged as spam by Gmail - it started happening when we moved from a shared host to a dedicated host.

I've configured SPF Records, Domain Keys and even DMARC records- however emails are still being delivered as spam, no matter the contents.

I've included my latest email headers below and any help would be greatly appreciated.

I've hidden our IP's and domain name for contingency, if you believe it is required please let me know and I can provide it

Regards

Edit: I've already followed every step on the linked question and my problem still exists - I feel like there's a fault with the way our emails are configured, however I cannot pinpoint where we're going wrong :(

7
  • Have you checked if your IP is on any RBLs?
    – EEAA
    Dec 7, 2015 at 13:08
  • Yea :( checked over 100 RBLs and all come back as OK Dec 7, 2015 at 13:29
  • I assumed at first it was a reverse dns issue - the server ip resolves as the server hostname rather than our domain name but there's no way for us to amend that Dec 7, 2015 at 13:31
  • I've followed that exact question Jenny D, I feel as though I've literally tried everything, I keep getting told to contact google to get our domain removed from their blacklist however they literally don't respond to any of the forms I've filled in Dec 7, 2015 at 13:32
  • @Reece Unfortunately, your best option may be to sign up for a Google Apps for Business trial (with which you get access to Google Support), and then engage them to see why emails sent to your Google Apps account are getting blocked.
    – EEAA
    Dec 7, 2015 at 13:59

1 Answer 1

0

With the caveat that you have obfuscated some things in your email, and have not posted the complete message:

The only serious problem I see with what you have posted is that some of your headers have been RFC 2047-encoded.

To: =?utf-8?B?UmVlY2UgTSBWYXVnaGFu?= <evolutionvapingtest@gmail.com>
Subject: =?utf-8?B?RXZvbHV0aW9uIFZhcGluZyB8IFlvcmtzaGlyZSBWYXBlciB8IEZsYXZvdXIgb2YgdGhlIFdlZWs=?=

This is done when a header needs to contain non-ASCII characters. However, on decoding them, we see that there aren't any non-ASCII characters, so there was no reason to encode them to begin with.

To: Reece M Vaughan <evolutionvapingtest@gmail.com>
Subject: Evolution Vaping | Yorkshire Vaper | Flavour of the Week

I've seen a couple of other messages where unnecessary encoding was used, also considered spam at Gmail. I recommend that you figure out what is doing this, and reconfigure it to encode headers only when absolutely necessary. To that end you may wish to visit our sister site Magento.

3
  • Perhaps Google just don't like you? It may also help to mark all of your test messages as Not Spam. Dec 7, 2015 at 14:39
  • I've actually considered that being an option! On a more serious note, I'm no expert but when we first purchased the dedicated server it came with what you could call a temp domain name (hostname) - I removed all reference to it but it still shows in the email headers, could that possibly be confusing things? I've set our domain name as the hostname in all of the settings but it still shows.... literally willing to pay someone at this point Dec 7, 2015 at 14:41
  • That's one reason why you should not obfuscate anything here if you can avoid doing so. Dec 7, 2015 at 14:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.