0

Over the weekend we upgraded our server, including SharePoint.

Previously we were using WSS3.0 on Server 2008R2. We moved to SharePoint Foundation 2010 on Server 2012R2.

We also have Exchange 2016 on the server, so we set the SharePoint port from 80 to 8800.

The move was completed successfully, all files are viewable, we can access the SharePoint WebDav shares, and can open files from WebDav shares.

However, the one issue we have is that any existing Office documents that we open come up as Read-Only. If I create a new file and save it, I can open and edit the file without and issue.

Text documents and anything not opened by Microsoft Office will open without issue.

One user has Office 2013 Home & Business. All other users are on a Office 2010 Professional VL.

The following is what I've checked and what we have tried.

  • WebDav is not installed for IIS.
  • All user permissions are correct.
    1. I've tried to open the documents with a user that has Full Control and one that has Contribute rights.
  • Changed Web Document handling from Strict to Pervasive.
  • Changed the ProtectedView settings, and data location paths.
  • Set IE to use 127.0.0.1 as a proxy.
  • Added the server name to the Intranet zone and Trusted zones in IE.
  • Added the OpenDocumentsReadWrite flag to registry.

I wanted to see if someone else has come upon this issue and have any information on resolving it or pointing me in the right direction.

Thanks.

0

I found the following article.

http://social.technet.microsoft.com/wiki/contents/articles/31406.sharepoint-office-documents-open-in-read-only-mode.aspx

After making the change to the registry for FSSHTTPOff the issue has gone away. Any Office document can be opened, edited and saved.

please follow the steps below in client computer to resolve the issue.

  1. On the client computer experiencing the issue click on "RUN" then type "RegEdit".
  2. Go to this path HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\14.0\Common\Internet
    • Note:For sharepoint 2013 the path is 15.0
  3. Right click and create new "DWORD" entry and give it a name of "FSSHTTPOff"
  4. Double click the new entry and enter 1 for the value.
  5. Once done you need to reboot the computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.