2

At our company, we have many Dell servers. We recently got another server, with an unlicensed iDRAC.

For various reasons, we like to change the SNMP community string from the default of 'public'. Unfortunately, having tried a few methods that would work on licensed iDRACs, I cannot find a way to do it on this machine.

Is there a way to change the SNMP community string on an unlicensed iDRAC?

I have tried:

racadm

This returns the following:

C:\Windows\system32>racadm set iDRAC.SNMP.AgentCommunity testpassword  
ERROR: SWC0242 : A required license is missing or expired.  
   Obtain an appropriate license and try again, or contact your service  
   provider for additional details.  
Required License -- RACADM  

ssh

Again, license issue:

C:\Users\jruskin>ssh root@10.150.100.3
root@10.150.100.3's password:

License Violation: "SSH"

Connection to 10.150.100.3 closed.

Web Interface

Without a license, the web interface is severely limited, and has no options for disabling or changing the accessible SNMP interface.

iDRAC Web Interface

If I'm honest, based on the message on the licensing screen ("For 500 or below series servers and blades, Basic Management features are standard"), I had assumed that the license would be included in some way (and this question may come down to "you need to get a license, go talk to Dell").

In the meantime, does anyone have any other methods for restricting access to the SNMP community stuff other than simply blocking all access to the iDRAC, or rendering it otherwise entirely inaccessible?

1

The reason should be obvious. Licensed = access to all features of which SNMP is one.

UNLicensed = no access to features of which SNMP is definitely one.

Prob be best to license it.

  • I'd agree, if SNMP were off by default. As it is, it's a bit of a potential security hole, that you surely must be able to fix without paying. – James Ruskin Dec 8 '15 at 15:44
  • It is probably part of the reason they leave it on so that you have to license it to set it up properly or disable it. – Kobus Dec 8 '15 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.