0

I have installed pfsense latest version and user are working on Phpstorm and Netbeans editors with git (https).

On gateway, I have installed pfsense server and configure transparent proxy using squid+squidguard`.

then Pfsense self sign certificate installed all machine and browsing is working fine but Issue is that, when user perform fetch/push operation etc on editor using git then getting some certificate related errors.

On server site, We can't change it (disable the https or no verification etc).

Please let me know how to resolve this error on client machine or pfsense firewall.

  • You'll want to at least give what error you're receiving... – gparent Dec 8 '15 at 16:17
  • I get "repository test has failed" error when make a clone in phpstorm, if i disable the https in pfsense or sslVerify = false then i am able to create clone. Also add ssl certificate in c:\User\Admin\..gitconfig : "sslCAInfo = /cert/mycert.cer" in windows 7. – Nullpointer Dec 14 '15 at 5:04
2

The client has to ignore the self-signed cert, not the server. This question seems to have what you are looking for: http://stackoverflow.com/questions/12537763/git-ssl-without-env-git-ssl-no-verify-true

| improve this answer | |
  • I don't want to disable ssl certificate. – Nullpointer Dec 14 '15 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.