0

I'm attempting to set up php-mssql in RHEL7. freetds is not available in the default RHEL repo, so I enabled epel as follows:

rpm -Uvh http://mirror.oss.ou.edu/epel/7/x86_64/e/epel-release-7-5.noarch.rpm
yum install freetds

That yields:

Error: Package: freetds-0.91-2.el6.x86_64 (epel)
           Requires: libgnutls.so.26()(64bit)
Error: Package: freetds-0.91-2.el6.x86_64 (epel)
           Requires: libgnutls.so.26(GNUTLS_1_4)(64bit)

RHEL installed gnutls-3.3.8-12.el7_1.1.x86_64 by default.

Is there a way through the woods?

  • 1
    You can use yum install epel-release instead of using rpm. – Brian Dec 8 '15 at 22:14
1

While not ideal, this seems to work.

rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-7.rpm
rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm
yum install php56w php56w-common
wget ftp://rpmfind.net/linux/epel/7/x86_64/f/freetds-0.95.19-1.el7.x86_64.rpm
yum install freetds-0.95.19-1.el7.x86_64.rpm
yum install php56w-mssql
# success
-3

After epel installed, yum install freetds-devel

  • 1
    This is obviously not the correct answer. Did you bother to read the question? – Sven Sep 14 '16 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.