0

I have a silly little problem I'm trying to solve:

I'm using Windows 10 Pro on an AD Domain. If I launch Internet Explorer in kiosk mode (%ProgramFiles%\Internet Explorer\iexplore.exe -k) either manually, or via the the startup folder (shell:startup), everything works great and IE launches in full screen.

I'm trying to deploy IExplore in kiosk mode via GPO. I want it to start when the user logs in (note, I am also using automatic-login deployed via GPO and it works great). I am using Scheduled Tasks in User Preferences via GPO in order to launch IE when the user starts their session.

This works fine except for the one silly little detail:

Although IE launches in mostly full-screen, the taskbar still remains visible, and it seems that focus is still being retained by the taskbar (I have to alt-tab to the IE kiosk window).

Again, this does not happen when manually launch kiosk mode, or when using the startup folder (but I don't want to have to manually setup the startup folder on every machine).

Any ideas how to solve this behavior?

  • this doesn't explain why iexplore.exe -k works fine when launching from the Startup folder, but not via GPO Scheduled Tasks... – Daniel Dec 9 '15 at 18:17
  • I looked into Windows 10 Kiosk mode. Problems: 1. Assigned Access only works with "Metro" style programs which were introduced in Windows 8. Internet Explorer is no longer available as a Metro program, and Edge apparently doesn't count either. In short, you cannot use a web browser currently in Assigned Access mode. 2. Even if Edge were available, the plugin that I need to use for this purpose does not work with Edge. 3. Shell Launcher is another option, but apparently is only available in Enterprise and Education version, and not in Pro (which is what I am using) – Daniel Dec 9 '15 at 22:55
0

Eh, I finally gave up an just created a GPP which puts a shortcut "%ProgramFiles%\Internet Explorer\iexplore -k" in Startup.

It works great. Not sure why using Scheduled Tasks has this problem with the Taskbar retaining focus.

0

You could just prevent the shell from launching. If you don't need windows explorer, either stop after it starts, or change it to something else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.