I have a Windows 2003 image with IIS6 installed that just installed a block of Windows Updates. This webserver was using port 443 and an SSL certificate properly up until this patch, and it will no longer respond at all on port 443 to requests.

I have tried removing and re-installing the certificate, and it will still not respond on port 443.

Is the metabase corrupted? Is this something I can easily rebuild?

-- UPDATE -- After some further investigation, this server image that is installed on the Amazon EC2, somehow invalidated its SSL certificates when I performed a 'bundle' operation on the AMI. Is there any way to avoid having to re-key an SSL cert when you launch a bundled AMI?

  • Do you know which updates were installed? Did you stage them in a test environment first? Oct 13, 2009 at 21:11

1 Answer 1


I think if you disable the Ec2Config service you can avoid this problem. My understanding is that after a bundle this service generates a new key for the server.

Note that this may have other implications.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .