0

My DNS domain for numeet.com (just a spare domain) was pointed to Route 53, and resolution of numeet.com and www.numeet.com is working fine.

However, a subdomain called learn.numeet.com is not working, despite a CNAME.

The main A record points to an elastic load balancer where a couple of servers are dealing with web traffic (once SSL is terminated on the ELB)

The CNAME resolves to a specific IP address of one of the above servers (the only one that has Moodle installed). That server has a vhost setup and an elastic IP address to the subnet on the server and HTTP is fully open (and already working with the ELB).

However, when 2 days after setting this up I try to got to http://learn.numeet.com, the DNS still does not resolve.

On the EC2 instance, I can run dig learn.numeet.com, and that resolves to the IP address fine. However, even from the EC2 server, ping learn.numeet.com doesn't work.

The record setup is as per the photo below: enter image description here

Is there a problem with Route 53 having multiple routes to the server (www.numeet.com via ELB and learn.numeet.com via Elastic IP) ?

What am I missing?

3

CNAME records must always point to another domain name, never directly to an IP address.

| improve this answer | |
0

OK, classic case of using a set of DNS records that work with one configuration, but not this one.

Classic 1 server setting

a: IP.OF.The.Server

cname www.example.com example.com

cname learn.example.com example.com

However, that doesn't work where the main domain has a different IP address

The simple solution is to delete the CNAME and replace it with an A record for learn.numeet.com

Just in case someone else find this problem here, the corrected setting was:

enter image description here

| improve this answer | |
  • The actual problem was that a CNAME can never have a literal IP address as its explicit target. That's never a valid configuration. A CNAME record, by definition, must return the canonical name of the host, while an A record must return the ipv4 address of the host. – Michael - sqlbot Dec 11 '15 at 19:12
  • As I discovered! However Amazon does allow me to set one using Route 53, with the net effect that a dig learn.numeet.com did return the ip address when nothing else would. – brianlmerritt Dec 13 '15 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.