4

We run several HP DL380 Gen8 servers as Windows 2012 R2 Hyper-V hosts. Randomly, they stop responding on the customer NIC (ie the one connected to the virtual switch). Customers are disconnected from VMs.

Luckily we have found that we can get to the server via the management NIC okay and we simply disable/re-enable the customer NIC and all is well again. This happens every few days and there seems to be no trigger.

I have ensured that the adapter drivers are the latest (v17.0.0.3 HP Ethernet 1Gb 4-port 331FLR / Broadcom NetXtreme).

Has anyone else experienced this? Could the cause be in the physical NIC, the driver or perhaps in the Hyper-V virtual switch?

  • Start your troubleshooting at the physical layer. What do the physical switch counters show? – joeqwerty Dec 11 '15 at 19:34
  • comment deleted - posted in error – Trichromic Dec 14 '15 at 9:40
3

Honestly, the short answer is that you need to switch to Intel nics. Broadcom has been trying to fix this problem for over a year and they still haven't licked it.

Avoid Networking Issues Hyper V

Virtual machines lose network connectivity when you use Broadcom

That second link brings you to a Microsoft site which will link you out again to driver pages that supposedly fix this problem. Speaking from personal experience, for what that's worth, it didn't work. We ended up buying Intel Nics and switching them on maintenance.

  • Thanks for the link to Aidan Finn's blog. there's some good advice there, especially regarding updates not applied via Windows Update. I had read that second link before, hence why I had VMQ off on the hosts already but I will now check if disabling on the VMs makes a difference. – Trichromic Dec 14 '15 at 9:34
1

Well, this is a known issue as described in this Microsoft kb article:

https://support.microsoft.com/en-us/kb/2986895

What really helped us in our case, was not only to disable the VMQ in all affected Network adapters properties as suggested by Microsoft, but also to disable it in the Virtual machine's properties (to uncheck “Enable Virtual Machine Queue” under each of the virtual machine settings). By default is it enabled.

See detail instructions here: Hyper-V Virtual Machines losing network connectivity under Server 2012 R2

  • We have VMQ disabled on the host and I thought that would prevent it working on the VMs too. I will go and ensure that they also have VMQ disabled. Thanks. – Trichromic Dec 14 '15 at 9:21
  • Did this resolve the problem for you? I also have a DL380 Gen8 with this problem running Server 2012 R2. – PandaNL May 30 '17 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.