0

The MSSQL installer does not go through - it's missing .NET 3.5 framework to complete.

Unfortunately I've been unable to solve this, what I've tried:

Manually download and transfer the /sxs folder(which should contain the driver) to the C: drive, hereafter running this command in powershell(with admin rights): install-windowsfeature -name NET-Framework-Core -source c:\sxs - It does indeed move on to install it, but gets stuck at 68%.

I've also tried downloading and transferring the .NET 3.5 installer itself from Microsoft, and going through the official way of installing it (Server Manager). Same thing applies - it gets stuck roughly 68% into the process, and hereafter just informs that the service-feature could not be installed.

Quite out of options. Help appreciated.

| improve this question | | | | |
  • There should be a much more descriptive error message than "it gets stuck". What does it say in powershell once the installation has failed? – Reaces Dec 14 '15 at 13:59
  • Possible duplicate of Unable to install .net 3.5 on Windows server 2012 – Reaces Dec 14 '15 at 13:59
  • @Reaches indeed I get the same trying to update from server manager. – cbll Dec 14 '15 at 14:00
  • @reaches you're right. Now that I look at it, it appears that the powershell output is due to lack of internet connection.. But I still have the same problem as the duplicate, the path is provided but it still fails(exactly same) – cbll Dec 14 '15 at 14:03
  • Perhaps this link can help you out then. – Reaces Dec 14 '15 at 14:29
1

I solved this by copying the .\sxs folder off the installation media for windows 8. Hereafter, I ran the command dism /online /enable-feature /featurename:NetFX3 /all /source:C:\sxs /LimitAccess and it installed fine.

| improve this answer | | | | |
0

Use this batch file:

@echo off
Title .NET Framework 3.5 Offline Installer
Dism /online /enable-feature /featurename:NetFX3 /All /Source:.\sources\sxs /LimitAccess
echo.
echo .NET Framework 3.5 should be installed
echo.
pause
| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.