2

Trying to update my server and I get this error. I have tried the suggestions at the bottom but no success. How can I resolve?

sudo yum update
Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main/latest                                                                              | 2.1 kB     00:00
amzn-updates/latest                                                                           | 2.3 kB     00:00
Resolving Dependencies
--> Running transaction check
---> Package python26.x86_64 0:2.6.9-1.80.amzn1 will be updated
---> Package python26.x86_64 0:2.6.9-2.83.amzn1 will be obsoleting
---> Package python26-botocore.noarch 0:1.3.1-1.38.amzn1 will be updated
---> Package python26-botocore.noarch 0:1.3.11-1.40.amzn1 will be an update
---> Package python26-devel.x86_64 0:2.6.9-1.80.amzn1 will be updated
---> Package python26-devel.x86_64 0:2.6.9-2.83.amzn1 will be an update
---> Package python26-libs.x86_64 0:2.6.9-1.80.amzn1 will be updated
---> Package python26-libs.x86_64 0:2.6.9-2.83.amzn1 will be an update
---> Package python26-ordereddict.noarch 0:1.1-2.5.amzn1 will be obsoleted
--> Processing Dependency: python26-ordereddict = 1.1 for package: python26-bcdoc-0.16.0-1.9.amzn1.noarch
---> Package python26-pygments.noarch 0:1.4-4.11.amzn1 will be updated
---> Package python26-pygments.noarch 0:1.4-4.12.amzn1 will be an update
--> Finished Dependency Resolution
Error: Package: python26-bcdoc-0.16.0-1.9.amzn1.noarch (@amzn-updates)
           Requires: python26-ordereddict = 1.1
           Removing: python26-ordereddict-1.1-2.5.amzn1.noarch (@amzn-main)
               python26-ordereddict = 1.1-2.5.amzn1
           Obsoleted By: python26-2.6.9-2.83.amzn1.x86_64 (amzn-updates)
               python26-ordereddict = 1.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
  • What you're seeing here is yet another example of the poor QA behind Amazon Linux. This literally should never have happened. – Michael Hampton Dec 15 '15 at 15:41
2

Same issue here - apart from notifying Amazon that one of their packages is broken, the only other course of action at this time is to wait.

By 'wait', you can run the other updates (--skip-broken) if you need the other packages that were also updated in the last 24 hours, or you can wait for the package to be fixed before updating everything that has been updated recently.

In my case, running --skip-broken didn't cause any other issues, but then my usage of python outside of the AWS CLI on the servers is very limited, and the existing working version of that package is still good even with the other packages being updated.

  • I have now raised it with Amazon (we have paid support) so I will update here when I get a response. – williamsdb Dec 16 '15 at 9:15
  • Contacted Amazon but in the meantime the package had already been fixed and the update is now working correctly. – williamsdb Dec 16 '15 at 13:33
  • Same here - all updates today worked as usual. Regardless of the nay-sayers, this is a very rare occurrence - I'm not thinking of switching from AWS Linux any time soon myself :) – PhillipHolmes Dec 16 '15 at 16:21
0

Grep this answer on the same question:

Yum update error - Requires: python26-ordereddict

Try use --skip-broken, this is safe

  • The OP already said he did. – MadHatter Dec 15 '15 at 11:59
  • Hi, as @MadHatter states I did already use --skip-broken. My issue is that yum still says that there are "4 package(s) needed for security, out of 6 available" so skipping still leaves the server not properly updated. Also I use yum-cron which, of course, now fails due to this error. – williamsdb Dec 15 '15 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.