5

I have an issue with 2 HP DL60 Gen9 servers. They each contains 2 x 500 G SATA HDDs. I've used Intelligent Provisioning to create a RAID 1 array using the HDDs however, the first issue I noticed is during the OS install process I'm still seeing two HDDs which is weird. Anyway, I tried the following scenarios (using an USB disk):

  • installed CentOS 6 and created a RAID 1 array during the OS install
  • installed CentOS 6 without any array
  • installed CentOS 7 and created a RAID 1 array during the OS install
  • installed CentOS 7 without any array
  • installed CentOS 7 using RAID + LVM

The problem is that after the install it doesn't boot, saying that no suitable boot device has been found. I did find Install GNU/Linux No System Disk Error -- HP Smart Array

Unfortunately, I am using GRUB but it still doesn't find it. I saw ewwhite's reply asking if a USB stick was used (which is the case for me). Problem is I don't have a DVD writer in the office and it will take 2 days if I get one. Could the fact that I am trying an install from an USB be causing these issues? Thanks in advance.

UPDATE

Talking to HP I actually reset everything to FACTORY settings (previously I only tried default settings) and re-created the logical drive. That seems to have fixed the issue and I am now able to boot into CentOS 7. However, the remaining issue is why am I still seeing 2 drives during the install process even though I have created a RAID 1 array using the HP Smart Storage interface.

  • Are you sure you're creating the R1 array? have you gone into ORCA or SSA (off the SPP) and checked? Almost certainly the USB will have nothing to do with this. – Chopper3 Dec 15 '15 at 11:56
  • 1
    Yes, I am 100% sure. If I don't create an array there's a BIOS warning saying that the RAID controller isn't configured. – Mugurel Dec 15 '15 at 12:00
  • Very odd that they would still show up though - I install via iLO or kickstart myself so can't really help further but there's lots of people around here who I'm sure will. – Chopper3 Dec 15 '15 at 12:03
  • I recommend using the ILO (find a key online) to do your installation. Can you specify which RAID controller is in your server? – ewwhite Dec 15 '15 at 12:04
  • Ok, I will try that as long as it allows me to do custom partitioning. I have a Dynamic Smart Array B149i – Mugurel Dec 15 '15 at 12:28
2

Remove the USB key before the boot loader is installed during the OS installation.

You may have written the boot loader to the wrong device. The SCSI enumeration changes when you involve USB devices at install-time; e.g. the USB key becomes /dev/sda, and pushes your internal disks to /dev/sdb.

Also see: Proliant dl380p gen8 Debian booting

  • I'll try that but the thing is after I installed it, I'm now seeing the 'CentOS' option in the One-time boot menu but when I select it nothing happens. Do you think it's worth using a CD/DVD? – Mugurel Dec 15 '15 at 16:05
  • That didn't work I'm afraid. Found a DVD writer and I'm trying the OS install now from a DVD. – Mugurel Dec 15 '15 at 16:46
  • Well, unfortunately, that didn't work. I'm still getting the unable to find UEFI bootable device. Any other suggestions? I've been on the phone with HP support and they don't know what's wrong yet. – Mugurel Dec 15 '15 at 17:06
  • Don't install in UEFI mode. Install in Legacy mode. – ewwhite Dec 15 '15 at 17:22
  • 1
    Tried again - can't even get it to boot from the DVD-ROM when I set it in Legacy Mode. – Mugurel Dec 17 '15 at 10:32
2

I may be late to this party - but I hit the exact same issue recently and came across this is as one of the relatively few questions on this point - I was installing Debian on a DL60 server - and spent two days not getting anything to work, until I followed a throw away line from another question somewhere (I am sorry I forget where) - which led me to the really easy answer here :

Set "Enable SATA AHCI" under "System Options" in BIOS (from startup default settings (F9) to get it booting from the hard drive under Debian control not HP control. If you don't so this you'll waste 2 days like I just did.....and that is literally the only change I had to make at the end of the day !! It means you simply ignore ALL the HP RAID stuff entirely, but you are still using the UEFI side of life as far as Debian is concerned......

Hope it helps someone

Andy

  • Can confirm. I had the exact same problem w/ CentOS 7 on a HP ProLiant DL380 G9 server. Setting Enable SATA AHCI solved my problem (and I can now have a SW RAID) – Denys Vitali Nov 11 '17 at 17:35
0

You mentioned: However, the remaining issue is why am I still seeing 2 drives during the install process even though I have created a RAID 1 array using the HP Smart Storage interface.

You will see 2 drives even after RAID Configuration because the CentOS cannot detect RAID Driver. I came across this on different HP servers. You will need to load driver on setup.

Confirm your RAID Controller model.

0

I hit the same thing installing RHEL 7 on a DL60. Apparently RHEL/Centos 7 is incompatible with the b140i Smart Array drivers on HP gen9 controllers. Here's how finally got RHEL to load on the DL60:

  1. Download the hpdsa (or hpvsa) driver from HP. For mine it is a B140i controller: http://h20565.www2.hpe.com/hpsc/swd/public/detail?sp4ts.oid=7304563&swItemId=MTX_186b4a75315c4de1ae2e93ee94&swEnvOid=4176
  2. On a Linux machine use the dd command to copy to a USB drive: dd if=hpdsa-..x86_64.dd of=/dev/sdc1)
  3. Boot the DL60 using the RHEL/CentOS disk. At the Installation Option screen press 'e' to edit the install command. Append 'modprobe.blacklist=ahci inst.dd' to the end of the line that starts with linuxefi: linuxefi /Images/pxeboot/vmlinuz inst.stage2=hd:LABEL-RHEL-7.0\x20Server .x86_64 quiet modprobe.blacklist=ahci inst.dd
  4. At the 'Driver disk device selection' enter 'r' to refresh. Select your USB drive from the list (sda1, etc.). Select the 'hpdsa' from the driver list. Select 'c' to continue.

http://h20565.www2.hpe.com/hpsc/doc/public/display?sp4ts.oid=3884098&docLocale=en_US&docId=mmr_kc-0135766

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.