I tried to install the latest nginx version (1.99) on my ubuntu 15.10. I want a nginx version >= 1.95 because I like to have http 2 support.
I followed the instructions I found on the internet for ubuntu 14.04, but which should be the same for ubuntu 15.10 (http://www.liberiangeek.net/2014/10/install-latest-version-nginx-ubuntu-14-10/):
Download Nginx repository authentication key:
cd /tmp/ && wget http://nginx.org/keys/nginx_signing.key
Install the repository key:
sudo apt-key add nginx_signing.key
Create a new repository file for Nginx
sudo nano /etc/apt/sources.list.d/nginx.list
Then copy and paste the lines below into the file and save it ("wily" is the Ubuntu codename for my 15.10 ubuntu version)
deb http://nginx.org/packages/mainline/ubuntu/ wily nginx deb-src http://nginx.org/packages/mainline/ubuntu/ wily nginx
But when I finally ran the command:
apt-get install nginx
I got the following error:
nginx : Depends: libc6 (>= 2.14) but 2.13-38+deb7u8 is to be installed Depends: libssl1.0.0 (>= 1.0.2~beta3) but 1.0.1e-2+deb7u17 is to be installed
So how can I solve this issue? Is there any way I can install nginx 1.99 (or 1.95) on my Ubuntu server?