I upgraded the Network Card Drivers for my Domain Controller but now it is seeing the local lan as a PUBLIC network which is messing with my firewall rules.

How do I switch it back to DOMAIN?


3 Answers 3


You can use Powershell to achieve this. First you have to list network profile


Use interface index to change the network interface to domain.

Set-NetConnectionProfile -InterfaceIndex 7 -NetworkCategory Domain

  • 4
    I tried that, and I am getting the error: set-netconnectionprofile : Unable to set NetworkCategory to 'DomainAuthenticated'. This NetworkCategory type will be set automatically when authenticated to a domain network. Sep 26, 2017 at 3:24
  • Be sure that you are using the rigth interface Index
    – Sam Doxy
    Oct 17, 2017 at 14:24
  • Had the same error as @KarlHenselin. Index was right. Had to remove the server from the domain, then rejoin.
    – Gustav
    Jan 6, 2019 at 12:31


net stop nlasvc as admin

if this works, you can set this service (nlasvc) to "start delayed"

  • 2
    This is how I was able to resolve the issue on my system after a power outage made this happen on my desktop. Using the Powershell method only resulted in "Unable to set NetworkCategory to 'DomainAuthenticated'." Jul 16, 2019 at 15:55

Here is the answer... https://social.technet.microsoft.com/Forums/windowsserver/en-US/98f41513-df6f-4065-975a-6d6dc2308a94/server-2012-r2-change-network-location-from-public-to-private

Reboot or disable/enable the NIC afterwards.

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – Swisstone
    Aug 12, 2022 at 4:35
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Aug 24, 2022 at 15:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .