2

I'm rolling out a test installation of EL7 with Apache 2.4. I copied my existing /etc/httpd/conf.d/ssl.conf to the new system, set up selinux, verified all the cert paths were kosher and systemctl httpd start started the service. Apache is running error free.

The problem is that my ssl.conf file is ignored. I'm being shown the default Apache page using

I tried moving /etc/httpd/conf.d/ssl.conf to /etc/httpd/conf.modules.d/ (first removing the existing 00-ssl.conf file), with the same result.

Where am I getting it wrong?

Edit 1 The error log shows this:

AH01630: client denied by server configuration: /www/virtualhosts/example.com

Where my ssl config has this:

DocumentRoot /www/virtualhosts/example.com

and

ll /www/virtualhosts/example.com
total 4
-rw-r--r--. 1 apache apache 21 Dec 18 14:32 index.php

index.php consists of:

<p>Hello World

I'm at a loss.

2

Got it. Apache 2.4 has additional security features. I needed to add this to /etc/httpd/conf/http.conf and restart the service.

<Directory "/www/virtualhosts/example.com">
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
</Directory>

I can haz website.

Also, I moved the default 00-ssl.conf file back in place (/etc/httpd/conf.modules.d/), and moved ssl.conf back to /etc/httpd/conf.d/ssl.conf.

Restarted the service and all is still well.

  • 1
    Do not forget to mark your answer as correct, thanks. – Froggiz Dec 18 '15 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.