0

OS: Debian 8.2, Apache: Apache/2.4.10 (Debian)

Since two days my apache2 "suddenly" starts to run on 100% cpu at night. The process does not stop then and I have run kill -9 to stop it in the morning. service apache2 stop does not work to stop the instance.

I guess it all started when I installed kolab (kolab.org) on my machine. I also installed owncloud before and did some smaller installs. Otherwise the Debian install is pretty much "fresh". But it started the night after installing kolab.

The problem seems to be triggered by a graceful restart at 6 in the morning. At least the logs hint into this direction.

And if I do manually: apachectl -k graceful I get exactly this apache2 process running on 100% cpu.

service apache2 restart does NOT trigger this problem!

I have no clue how to proceed further to find the problem.

  • 1
    uninstall kolab and test again? if problem disapear, contact kolab for a fix – yagmoth555 Jan 24 '16 at 0:19
7
+25

The trouble with this kind of question is that Q&A is not great for doing remote diagnostics. You have basically chucked a bunch of information at the internet and screamed HALP!. You are trying to force us to go into tech support mode and to hold your hand through a series of reverse Q&A till we can diagnose your problem for you. That is not Q&A and the platform is not designed for and does not cope well with is.

You should learn to help yourself carry out basic diagnostic steps and gather information from which you can make an informed decision. At best you will be able to solve your own problem. At worst you will be able to present your findings here in a much more focused manner.

You should use scientific method to help solve the problem. The first thing I would do is make a list of the stuff I installed and configured over and above the base OS. You've already done this and even suspect one component.

Remove/disable the component you are suspicious of and run some tests.

  • If the problem goes away then the troublesome component is known and you can focus your ongoing testing on it.

  • If the problem persists then disable/remove another component. Rinse and repeat as necessary.

  • Fair enough! I guess you are right. I was just hoping that this is a known problem an someone could point me closer to the problem. I will try to solve it when I have time and update the thread here. Thanks! – Michael Jan 24 '16 at 9:37
2

https://issues.kolab.org/show_bug.cgi?id=5225

If you read down a bit, you'll see that Kolab doesn't support Debian's apache2. Might that be your issue? Symptoms sound similar.

0

I have Owncloud installed and my server was running fine, then suddenly it was eating up my entire system, not just apache but everything that my machine had to shutdown itself.

The problem was that I did something to Owncloud that caused an error. But it was not the error that was the problem but the LOG FILE. The log file grew so big that the system that was monitoring the logs caused the system to crash.

See if your logs are being rotated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.