3

I have a spamassassin daemon used by exim on a FreeBSD 9.3 System that tries to use /nonexistent for its temp files and bayes-filter storage.

Passing the username or a home directory via the daemons flags in /etc/rc.conf does nothing to change this behaviour.

spamd_flags="-c -u spamd -H /var/spool/spamd"

The child processes spawned by the initial process are run by the user spamd (whose home directory is /var/spool/spamd), but it still tries to use /nonexistent. The permissions of the directory are correct:

drwxr-xr-x   3 spamd     spamd    3 Dec 20 18:15 spamd

Setting a bayes_path in /usr/local/etc/mail/spamassassin/local.cf does not change this behaviour either.

Apparently I'm not the only one who had the problem

2

As it turns out, the problem has nothing to do with spamassassin itself, it is the way it is used by exim. In my exims configuration I had this line in its ACL section:

warn    spam       = nobody

when I replaced that with

warn    spam       = spamd

everything worked as intended

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.