0

I'm currently working on setting up my new VPS in a way so my emails dont get into the spam folders (ie Gmail, Hotmail etc). For all this to happen, all the DNS/SMTP configurations need to be setup correctly. Using mail-tester.com I've achieved a 8.2 out of 10 of which, there's one certain thing I just can't solve.

You can find my mail-tester results here: http://www.mail-tester.com/web-dWaMuK

Problem:

-1  FSL_HELO_BARE_IP_2  IP used in the HELO request
The hostname must be a domain name, not an IP-address
-0.865  RCVD_NUMERIC_HELO   Received: contains an IP address used for HELO

I have a VPS from TransIP running on CENTOS 7.1 with a WHM/cPanel setup.

I went through several tutorials to set it up correctly and this is what I have done so far:

According to some googling the answer would be to setup a hostname as the rDNS (which I did), but for some reason it still sees the IP.

What am I overlooking?

P.S. the rDNS in the header and mail-tester report still needs to be refreshed to the correct rDNS (charlotte.studiomod.us). But even if it refreshes to the correct rDNS, I still get the same error.

This is what the header of the email displays:

Received: by mail-tester.com (Postfix, from userid 500) id 06909A8A7E;
    Tue, 22 Dec 2015 21:44:46 +0100 (CET)
Authentication-Results: mail-tester.com; dkim=pass  reason="2048-bit key;
 unprotected key"   header.d=adamkramer.nl header.i=@adamkramer.nl
 header.b=brI/kj1q; dkim-adsp=pass; dkim-atps=neutral
X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on mail-tester.com
X-Spam-Level: *
X-Spam-Status: No/1.8/5.0
X-Spam-Test-Scores: DKIM_SIGNED=0.1,DKIM_VALID=-0.1,DKIM_VALID_AU=-0.1,
    FSL_HELO_BARE_IP_2=1,RCVD_NUMERIC_HELO=0.865,SPF_PASS=-0.001
X-Spam-Last-External-IP: 149.210.247.192
X-Spam-Last-External-HELO: charlotte.studiomod.us
X-Spam-Last-External-rDNS: studiomod.us
X-Spam-Date-of-Scan: Tue, 22 Dec 2015 21:44:46 +0100
X-Spam-Report: * -0.0 SPF_PASS SPF: sender matches SPF record   *  0.9
 RCVD_NUMERIC_HELO Received: contains an IP address used for HELO   *  0.1
 DKIM_SIGNED Message has a DKIM or DK signature, not necessarily    *     
 valid  * -0.1 DKIM_VALID_AU Message has a valid DKIM or DK signature from
 author's   *       domain  * -0.1 DKIM_VALID Message has at least one valid
 DKIM or DK signature   *  1.0 FSL_HELO_BARE_IP_2 No description available.
Received-SPF: Pass (sender SPF authorized) identity=mailfrom;
 client-ip=149.210.247.192; helo=charlotte.studiomod.us;
 envelope-from=hi@adamkramer.nl; receiver=web-dwamuk@mail-tester.com
Authentication-Results: mail-tester.com; dmarc=none
 header.from=adamkramer.nl
Received: from charlotte.studiomod.us (studiomod.us [149.210.247.192])
    by mail-tester.com (Postfix) with ESMTPS id C68D7A6B05
    for <web-dWaMuK@mail-tester.com>; Tue, 22 Dec 2015 21:44:44 +0100 (CET)
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed;
    d=adamkramer.nl; s=default; h=Message-ID:Subject:To:From:Date:
    Content-Transfer-Encoding:Content-Type:MIME-Version;
    bh=sppGM44qRiT1lp/+/J/v0fXBV/FUiCZW3eSPSLRfKZ0=;
 b=brI/kj1qmqbYsbC6FyBpERQHyf
    /6DPq0KZ9zfVNSHJdZ4O66aUTdFGrWKLlLsOWTXWJVc7iDX78cLJHMvkE0jqUKfQINKJGMm2K4r
    3Q
    OP3aKPoNuLppE1rd4HW80KLUBgS0rQtTg4lzcf1kyPpZoZMGMXlKyNBMoiq5Ifqfw6kbMoLM5F2
    sS
    jEnHrjQhLgVaPm3Ujei+jrhnmD8Ey0KWZT5AxrLBf5MvLKQxaaioOx+bewm8Lu/CcqvkBLUxmYI
    /m
    V0BRGmEN4I6o5P+CJg7AjtugsnzNlBxqs8Xs8X/hmCtXKSo1pjptn0DTczSVAgzmExCKYI89S9a
    D5  5R+ZVFmw==;
Received: from [::1] (port=41793 helo=149.210.247.192)
    by charlotte.studiomod.us
    with esmtpa (Exim 4.86) (envelope-from <hi@adamkramer.nl>)
    id 1aBTnj-0004ke-2M for web-dWaMuK@mail-tester.com;
    Tue, 22 Dec 2015 21:44:55 +0100
MIME-Version: 1.0
Date: Tue, 22 Dec 2015 21:44:54 +0100
From: Adam Kramer <hi@adamkramer.nl>
To: web-dWaMuK@mail-tester.com
Subject: Testing my email
Message-ID: <6c2118033c11b8be94dd356a2dde55a4@adamkramer.nl>
X-Sender: hi@adamkramer.nl
User-Agent: Roundcube Webmail/1.0.6
X-AntiAbuse: This header was added to track abuse, please include it with
 any abuse report
X-AntiAbuse: Primary Hostname - charlotte.studiomod.us
X-AntiAbuse: Original Domain - mail-tester.com
X-AntiAbuse: Originator/Caller UID/GID - [47 12] / [47 12]
X-AntiAbuse: Sender Address Domain - adamkramer.nl
X-Get-Message-Sender-Via: charlotte.studiomod.us: authenticated_id:
 hi@adamkramer.nl
X-Authenticated-Sender: charlotte.studiomod.us: hi@adamkramer.nl
Return-Path: hi@adamkramer.nl
Content-Type: text/plain; charset=US-ASCII; format=flowed
Content-Transfer-Encoding: 7bit

Testing this to see if it works

closed as off-topic by Ward, MadHatter, Roman, Jim B, mdpc Feb 29 '16 at 23:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

2

The Received header that has a numerical HELO is not the one with the HELO provided by Exim. Exim is sending charlotte.studiomod.us.

The HELO that is being complained about is the one provided by the program you are using to send your mail: roundcube.

Selecting only Received headers from your mail makes this easier to see: the first line is internal to mail-tester, the second is mail-tester saying that it got the mail from charlotte (format is HELO (rDNS [IP]), the third is charlotte saying it got the mail from roundcube, and this last one is the only one saying that the helo is the IP address.

Received: by mail-tester.com (Postfix, from userid 500) id 06909A8A7E;
    Tue, 22 Dec 2015 21:44:46 +0100 (CET)
Received: from charlotte.studiomod.us (studiomod.us [149.210.247.192])
    by mail-tester.com (Postfix) with ESMTPS id C68D7A6B05
    for <web-dWaMuK@mail-tester.com>; Tue, 22 Dec 2015 21:44:44 +0100 (CET)
Received: from [::1] (port=41793 helo=149.210.247.192)
    by charlotte.studiomod.us
    with esmtpa (Exim 4.86) (envelope-from <hi@adamkramer.nl>)
    id 1aBTnj-0004ke-2M for web-dWaMuK@mail-tester.com;
    Tue, 22 Dec 2015 21:44:55 +0100
  • So the solution is as simple as using a different mail program to send emails with? Or is it possible to correct this? – adamk22 Dec 23 '15 at 11:13
  • You must correct the roundcube configuration (only if you want to use roundcube, of course, but as far as I know roundcube is a good choice of webmail). It seems that roundcube uses "server_name" as HELO. Best bet would be to look for the IP in the roundcube configuration and replace it with either charlotte.studiomod.us or localhost. – Law29 Dec 23 '15 at 12:03
  • I tried it with a different webmail service and I actually got a 10/10 on mail-tester.com. Never thought this would be a possible issue. Thank you so much! Ill look into changing the configuration of roundcube and assuming this is the solution. Thanks for the help! – adamk22 Dec 23 '15 at 12:42
  • Changed the smtp helo settings of roundcube to the hostname and aced the mail-tester test. Thanks! – adamk22 Dec 23 '15 at 13:37
  • You're welcome, and thanks for the accept. I've edited my answer to explain a bit more. – Law29 Dec 23 '15 at 19:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.