I have just demoted our Windows Server 2012 Domain Controller. Removed all services, and then did a fresh install of Windows Server 2012 R2. I gave the server the same IP address and host name that it had previously. I have just promoted it to a DC again. The problem I am having is that I can not remote desktop to the server using it's host name. I get the following error:

Remote Desktop cannot verify the identity of the remote computer because there is a time or date difference between your computer and the remote computer. Make sure your computer's clock is set to the correct time, and then try connecting again. If the problem occurs again, contact your network administrator or the owner of the remote computer.

I can assure you that the date, time (including AM/PM), and timezone are all correct on both the client and server. I have Googled this error and a lot of articles point to a DNS issue. However, DNS seems to be working fine on this server. Many clients are using this server as their DNS server without any issues. I can't find anything in event viewer either.

The only other far-fetched idea that I have is that when I demoted this DC something didn't get cleaned up properly, and it is still thinking that I am trying to remote into the old server. Although, I didn't get any errors when I demoted the DC.

Any help is appreciated.


I failed to mentioned that this was a Virtual Machine. The time was off on the host itself. After I fixed the time, I could remote in via host name. However, I don't know how the server knew anything about the host. For all it knows, it is a physical machine. And it was using a centralized server for NTP. But hopefully this can help someone out in the future.

Thank you all for your help.


Your workstation is storing connection data/certificate data for the old server and using it for the new server since they have the same hostname.

Navigate to HKEY_CU\Software\Microsoft\Terminal Server Client\Servers.

Delete the key named the same as the server.

  • I have actually already tried this. I even tried from a machine that has never remoted into this server, and I get the same error. – dschuett Dec 23 '15 at 13:16

Just to add to this and close the loop, there's a good chance that your hypervisor has some sort of heartbeat/time synchronization setup and this is what is being synced(or is trying to sync) with the VM. If it's Hyper-V you can find the setting in Integration Services from Hyper-V manager.

I'm dealing with a similar situation where we lost power at one of our sites for some time and the Host time was off by 2 hours.


Is there another DC, so that DNS can run? Or did you setup DNS already? Anyway, I'm assuming that you have a functioning DNS server.

Also assuming that you can RDP to the new server via IP.

Try running ipconfig /flushdns at a prompt line on the workstation, and then reboot.

  • Yes there is another DNS server. I have tried flushing dns and rebooting with no luck. I have also tried setting the server to use the other DNS server instead of itself. – dschuett Dec 23 '15 at 13:24
  • Are you able to RDP to the server by its IP? – Dr.Ping Dec 23 '15 at 13:25
  • Yes. I found the problem. I updated the original post. Thanks for your help. – dschuett Dec 23 '15 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.