-3

I have a nat rule in my firewall to allow port 22 traffic through pfsense. I am able to SSH into my server but sftp through filezilla is getting timed out and not connecting.

I tried with the local ip of the server and sftp worked fine. The only problem is when it pass through pfsense.

Not sure why sftp is not working behind the NAT. At the same time SSH works without any issue.

closed as off-topic by mdpc, Wesley, Jenny D, kasperd, mgorven Dec 27 '15 at 22:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on Server Fault must be about managing information technology systems in a business environment. Home and end-user computing questions may be asked on Super User, and questions about development, testing and development tools may be asked on Stack Overflow." – mdpc, Wesley, Jenny D, mgorven
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    It appears that you have forgotten to ask a question. It would also be good to see logs from the server and the client. – Iain Dec 26 '15 at 12:27
  • Give me output of this command: telnet <ip> 22 – Nullpointer Dec 26 '15 at 14:06
  • 3
    Sounds like an issue in filezilla. Are you definitely connecting using SFTP and not FTPS? – Xyon Dec 26 '15 at 16:07
  • Try another SFTP client, perhaps PSFTP (aka PuTTY). – Cristian Ciupitu Dec 27 '15 at 13:02
  • Provide a screenshot of pfsense rules – Nullpointer Dec 27 '15 at 13:16
0

Did the following and it fixed the issue.

  • Re-added the NAT rule for port 22 in pfsense
  • Upgraded Filezilla to latest version.

Not the answer you're looking for? Browse other questions tagged or ask your own question.