7

Running debian (Linux Rick 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) x86_64 GNU/Linux)

Looking at my cpuinfo I can see I have vmx support:

flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt aes lahf_lm ida arat dtherm tpr_shadow vnmi flexpriority ept vpid

The host and guest OS(Centos minimal ISO) are both x64 so the architecture is the same between the two of them.

Following these steps to create a new VM from an ISO I get a warning about hardware acceleration support:

  1. Create a new qcow2 file for the VM: sudo qemu-img create -f qcow2 /var/lib/libvirt/images/centos01.qcow2 8192
  2. Start network adapter: sudo virsh net-start default
  3. sudo virsh net-autostart default
  4. Create virtual machine from ISO: sudo virt-install -r 2048 --accelerate -n centos01 -f /var/lib/libvirt/images/centos01.qcow2 --cdrom /home/morty/ISOs/CentOS-7-x86_64-Minimal-1511/CentOS-7-x86_64-Minimal-1511.iso

And I get this warning:

WARNING  KVM acceleration not available, using 'qemu'

The VM is running, but I guess KVM acceleration isn't in affect? How can I enable acceleration and what am I missing without it?

5

Verify that Virtualization Technology (VT) is enabled in your server's BIOS. Reboot your server and press F2 during POST to go into the BIOS, then select Processors Settings, and verify Virtualization Technology is Enabled. Save and Exit and let the server boot up

One more thing to do is to manually change the xml file from type=qemu to type=kvm and start the guest

  • What xml file? Can you clarify. Thx – José Ibañez Feb 8 '18 at 13:35
  • I am referring to the domain XML description where you have the definition of your virtual machine. – Alaa Chatti Feb 12 '18 at 10:28
0

In case of running inside hypervisor nested virtualization has to be supported.

For Hyper-V nested virtualization can be enabled by PoserShell (as Administrator) command:

Set-VMProcessor -VMName ubt18 -ExposeVirtualizationExtensions $true

where ubt18 is name of virtual machine.

0

This went away for me when I ran virt-install as root. Almost too simple...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.