0

At first I was using 'example.com' as my MX record and everything worked fine, IMAP, SMTP, sending mails from the mail clients. And then I changed my mx record to 'mail.example.com' and everything turned into mess.

When I reconfigured the mail clients to use 'mail.example.com' again in server settings, it didn't work, probably some wrongdoings in postfix, but due to my deadline I decided to cut time and revert the MX record back to 'example.com'.

I am using iRedMail (Dovecot/Postfix) as mail server. I have the roundcube as my main webmail and rainloop as my second webmail. I am doing fine with the iRedmail main roundcube sending emails from webmail but I still have these error on other webmail clients nor desktop/android mail clients

enter image description here The hereby screenshot is Rainloop server settings. It always fails even though I reverted the settings back again

  • say the MX record for your domain was example.com and changing it to mail.example.com shouldn't be an issue unless both A records are pointing to the same IP. Can you confirm this? – clement Dec 29 '15 at 6:36
  • I was at first changed the mx record from domain.com to mail.domain.com and added a record mail.example.com pointing to IP. then in my postfix main.cf i edited the myhostname and myorigin to mail.domain.com and keeping the mydomain to domain.com. not working. anyway reverting back now works okay after 8 hours propagation(?) the pending email started to come one by one. and i have also fixed the stream_socket_client connection refused issue with rainloop webmail – pasaisea Dec 29 '15 at 10:44
0

Problem Resolved.

The iRedMail - Rainloop combination now works fine.

The root of the problem turns out that my own server ip is banned in fail2ban which makes the mail can be accessed in anywhere else than the server's own ip. (i know its ridicoulous but i found this out when i cant even access my own domain or even ip address in my server's web browser, only localhost works.

the fail2ban also messed up the dns hence trying incoming/outgoing settings using the mx record will result error "stream_socket_client unable to connect to tcp connection refused. That error makes my server's ip address ports (25, 143, 993) seemed liked they are not open but they ARE. I am using webmin, disabling the fail2ban immediately resolved all the socket connection refused errors.

Hope that this can be helpful to anyone who does iRedmail-Rainloop combination.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.