0

I'm having trouble configuring IPv6 routing under KVM virtualization, and I need your help!

On the host machine. It uses bridge (named br0) to give its guest machines Internet access.

On the guest machines running on the host, the IPv6 gateway is set as the IPv6 address of the host.

The problem is: on the virtual machine, "ping6 ipv6.google.com" gives:

ping6 ipv6.google.com
PING ipv6.google.com(nuq04s29-in-x0e.1e100.net) 56 data bytes
From [hostname] icmp_seq=3D1 Destination unreachable: Address unreachable

It seems that it can resolve the address but cannot reach the gateway.

"ip neigh show" gives the following output:

ip -6 neigh show
fe80::212:f2ff:fe9a:1700 dev ens3  FAILED
[IPv6 address of host machine] dev ens3  FAILED

While on the host machine, everything works fine.

Both systems are running latest CentOS 7.

I'm looking forward to your response.

Thank you!

  • 1
    Is the host really the IPv6 router for the link? That would be unusual. – Michael Hampton Dec 28 '15 at 18:33
  • I have tried to use either the host or the gateway of host as the gateway of the guest. Neither works. – Qi Xi Dec 28 '15 at 18:36
  • 2
    Does the host have IPv6 connectivity? What instructions did your provider give you? – Michael Hampton Dec 28 '15 at 21:26
1

After a lot of investigations and trials, I have finally find the solution to my own question.

Just to post it here in case others are having the same issue:

What I did was only adding a single line in /etc/sysconfig/network

IPV6FORWARDING=yes

And after a restart of the network using "service network restart", suddenly the issue was completely solved.

FYI, the file /etc/sysconfig/network should has four lines now:

NETWORKING_IPV6=yes
NETWORKING=yes
IPV6FORWARDING=yes
HOSTNAME=[***host name***]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.