1

I have a rhel 6.6 box with python 2.6 installed on it. I have configured epel repo. Now when i do a

"yum install -y cloud-utils cloud-init parted git", it gives me the following error.
--> Finished Dependency Resolution
Error: Package: python-boto-2.38.0-1.el6.noarch (epel)
           Requires: python-requests
Error: Package: cloud-init-0.7.4-2.el6.noarch (epel)
           Requires: python-argparse
Error: Package: cloud-init-0.7.4-2.el6.noarch (epel)
           Requires: PyYAML
Error: Package: python-boto-2.38.0-1.el6.noarch (epel)
           Requires: python-six
Error: Package: cloud-init-0.7.4-2.el6.noarch (epel)
           Requires: python-requests

Even though i have installed the dependent packages using pip, i still get the same error.

FYI,

[root@rhel6-64bit yum.repos.d]# pip install requests argparse PyYAML six

 Requirement already satisfied (use --upgrade to upgrade): requests in
 /usr/lib/python2.6/site-packages Requirement already satisfied (use
 --upgrade to upgrade): argparse in /usr/lib/python2.6/site-packages Requirement already satisfied (use --upgrade to upgrade): PyYAML in
 /usr/lib64/python2.6/site-packages Requirement already satisfied (use
 --upgrade to upgrade): six in /usr/lib/python2.6/site-packages

So, does cloud-init package require python 2.7 or higher. Can anyone suggest something. Any help shall be deeply appreciated

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.