2

I have a server in my local network that connects to an external VPN server and gets assigned the public IP address 2a02:c200:1:10:3:0:4315:2. Currently, when other computers in my local network access the server using its public IP address, the connection is naturally routed over the internet via the VPN server. I would like to set up my network to route connections to the public IP address of the server locally.

Basically, I need to set up a route 2a02:c200:1:10:3:0:4315:2/128 via fe80::baae:edff:fe79:122 (which is the local address of the server).

The router in my local network does not let me specify static IPv6 routes. So I am trying to set up a router advertisement on the server that advertises the route automatically. Unfortunately, I cannot find any documentation about advertising routes with radvd.

Like in this question, I have configured radvd as follows:

interface enp0s25 {
    AdvSendAdvert on;
    AdvDefaultLifetime 0;

    route 2a02:c200:1:10:3:0:4315:2/128 {
    };
};

This is the advertisement that arrives on my computer (shown using radvdump):

#
# radvd configuration generated by radvdump 2.11
# based on Router Advertisement from fe80::baae:edff:fe79:122
# received by interface wlp2s0
#

interface wlp2s0
{
    AdvSendAdvert on;
    # Note: {Min,Max}RtrAdvInterval cannot be obtained with radvdump
    AdvManagedFlag off;
    AdvOtherConfigFlag off;
    AdvReachableTime 0;
    AdvRetransTimer 0;
    AdvCurHopLimit 64;
    AdvDefaultLifetime 0;
    AdvHomeAgentFlag off;
    AdvDefaultPreference medium;
    AdvSourceLLAddress on;

    route 2a02:c200:1:10::/128
    {
        AdvRouteLifetime 30;
    }; # End of route definition

}; # End of interface definition

As you can see, the route prefix got truncated for some reason. Unrelated to that, my computer (Linux) does not set up any route, despite setting net.ipv6.conf.all.accept_ra_rt_info_max_plen = 128.

Before I added AdvDefaultLifetime 0;, a route default via fe80::baae:edff:fe79:122 was set up, which is not supposed to be, so I followed the advice from this mail to add this parameter.

Does anyone have an idea what I could be doing wrong, or a link to some documentation about advertising routes with radvd?

3
  • Hmm, that should work. Jan 2 '16 at 11:06
  • Do you have any idea why the prefix gets cut off?
    – cdauth
    Jan 2 '16 at 16:10
  • @cdauth Did you inspect the traffic on the wire to see if it got truncated before or after being sent over the network?
    – kasperd
    Jan 3 '16 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.