3

Situation

in our environment we are using the following servers to deploy printers in our domain forest:

  • Windows Small Business Server 2008: contains the group policy to deploy the printers
  • Windows Standard FE Service Pack 2: file and print server which contains the shared printers to deploy

Problem

I have a group policy assigned to 2 computers in our domain. One is a 64bit Windows 10 the other one is a 64bit Windows 7.

Details of the gpo:

Computer management > Preferences > Control panel settings > Printers

Here I have defined 11 TCP/IP printers to deploy with an update action. So I have entered the IP of the printer and linked to the printer on the file and print server.

The problem is, that some printers aren't visible in the client control panel > printers and devices.

Other details

  • I am logged in as a admin to perform the gpupdate on the client.
  • When I manually add the printer with the same driver it works perfectly
  • All the ports of the deployed printers are added to the client computer but some of them aren't mapped to a printer

What can be the cause of this?

UPDATE

Using the gpresult /H command I have found the error code on the printers that were not deployed:

0x80070bcb

UPDATE 2

Added a new policy Points and print restrictions and disabled the point and print restrictions setting.

Still the same...

When I go to the shared printer on the computer I can manually add this printer perfectly.

UPDATE 3

New error code in the gpresult: 0x80070706

UPDATE 4

Error 0x80070706 is solved.

So still facing the 0x80070bcb error for some printers.

The weird thing is that on the Win7 computer other printers have this error then on the Win10 and vice versa...

UPDATE 5

Ok now we are getting somewhere. I have edit the local group policy on the Win7 computer and set the Point and print restrictions settings to disabled.

Did a gpupdate /force and now all the other printers are deployed.

But I can't do this for all 70 computers. How can I deploy this setting in my group policies on my server?

I have disabled this setting under User configuration > Administrative templates > Printers.

Under Computer configuration > Administrative templates > Printers this setting in not available.

But that doesn't work.

UPDATE 6

Problem solved! View answer with details!

  • In the gpo settings. Click the Advanced tab, click to run at user level. Iam far from my pc (I go from memory for the setting name), but check that please and return to me. – yagmoth555 Jan 4 '16 at 12:33
  • I can't find the advanced tab or run at user level property... – Mivaweb Jan 4 '16 at 13:18
1

The error code you are getting (0x80070bcb) refers to an issue typically with driver downloads, specifically related to UAC prompts.

See here for a good explanation: Deploying printers via GPO

Specifically:

This basically means that the client couldn’t download the driver, but the real reason is because of UAC and the computer not requesting permission to install a driver. Thankfully there is a Policy that we can enable that will allow us to set the permission requirements during printer driver installation. Using the Point and Print Restrictions Policy we can enable printer driver installation without it getting hassled by UAC. Under Windows Vista it is a User Policy and on Windows 7 it is a Computer Policy (I have both enabled for good measure).

So enable the Point and Print Restrictions Policy and change the following options:

  • When installing drivers for a new connection: Do not show warning or elevation prompt
  • When updating drivers for an existing connection: Show warning only
  • view update 2, tried this but still no luck.... – Mivaweb Jan 4 '16 at 14:11
  • Have you made sure this new setting is applied to the desktops? (gpupdate /force). If so, what happens on a desktop that has UAC fully disabled and then you run the printers GPO? Do they install fine? – TheCleaner Jan 4 '16 at 14:14
  • I am sure. Using the gpresult I see the Point and print restrictions disabled. Also UAC is disabled but still the same. Still the error code 0x80070bcb – Mivaweb Jan 4 '16 at 14:25
  • I see now also another error code: 0x80070706 – Mivaweb Jan 4 '16 at 14:26
  • Take a look here: claymoore.wordpress.com/2009/02/04/… - – TheCleaner Jan 4 '16 at 14:30
0

Ok, after some hours spending and searching I have found the solution. All of my printers are now deployed on the Win7 and Win10 computers.

The fix was to update the ADM files on my Windows server because the setting Point and print restrictions wasn't available under Computer configuration.

Then set this also disabled, did a gpupdate /force and voila, all printers deployed!

Many thanks to @TheCleaner also!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.