4

Have been struggling for a day already and can't find solution. When try to send mails to some hosts:

Jan  5 10:31:37 vps**** sm-mta[2192]: STARTTLS=client, relay=mail-x.*****.co.uk., version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Jan  5 10:31:37 vps**** sm-mta[2192]: u059Vb4d002190: to=<****@****.co.uk>, ctladdr=<root@vps****.ovh.net> (0/0), delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=124764, relay=mail-x.****.co.uk. [212.46.138.29], dsn=5.1.8, stat=Service unavailable

After some study found that it might be TLS problem so tried to disable and add:

Try_TLS:   NO

but then I get:

Jan  5 10:33:56 vps**** sm-mta[2375]: ruleset=try_tls, arg1=mail-x.****.co.uk, relay=mail-x.****.co.uk, reject=550 5.7.1 <****@****.co.uk>... do not try TLS with mail-x.****.co.uk [212.46.138.29]
Jan  5 10:33:56 vps**** sm-mta[2375]: u059XuVY002373: to=<****@****.co.uk>, ctladdr=<root@vps****.ovh.net> (0/0), delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=124764, relay=mail-x.****.co.uk. [212.46.138.29], dsn=5.1.8, stat=Service unavailable

My sendmail version and settings: 8.14.4 on Ubuntu

============ SYSTEM IDENTITY (after readcf) ============
(short domain name) $w = vps****
(canonical domain name) $j = vps****.ovh.net
(subdomain name) $m = ovh.net
(node name) $k = vps****.ovh.net
========================================================

Any ideas?


Additional info:

Sending a test message in verbose mode generated the following error:

554 5.1.8 : Sender address rejected: MX record not found

5

Sendmail: Debugging outgoing SMTP session

As root send a test message with full tracking of the SMTP session.
Usually it provides some useful hints.

#!/bin/sh

RECIPIENT='****@****.co.uk'

# -i  : sendmail will rewrite lines starting with dot
# -Am : use sendmail.cf instead of submit.cf (usually requires root privileges) 
# -v  : use verbose mode (track SMTP session to STDERR)
# --  : separate command line arguments and recipients list
/usr/sbin/sendmail -i -Am -v -- $RECIPIENT <<END
Subject: test message
To: $RECIPIENT

test message body   
END

sendmail.sendmail(8) - man page

  • Thank you, I get: 250 2.1.0 Ok >>> RCPT To:<****@****.co.uk> >>> DATA 554 5.1.8 <root@vps****.ovh.net>: Sender address rejected: MX record not found 554 5.5.1 Error: no valid recipients Postfix sends e-mails to this host without a problem. – Amundio Jan 5 '16 at 13:02
  • It seems that remove mail sender rejects your envelope sender (as used MAIL FROM:) because the sender domain does not have an MX DNS record. Is your serveer based on static IP address? – AnFi Jan 5 '16 at 13:26
  • Yes, it was the case, had to change the envelope and worked like a charm. – Amundio Jan 5 '16 at 13:43
  • Do you want to fix TLS problem too? It is most likely caused by self-signed certificate. Making your sendmail check MD5 checksum of the certificate may be a good way to fix it. – AnFi Jan 5 '16 at 14:00
  • Thank you Andrzej. Yes it's due to self signed certificate. Will try to do the MD5 checksum. Any hints on it? Is it an option in the config? – Amundio Jan 6 '16 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.