4

I'm trying to install a .vib on an ESXi server. This specific one needs an acceptance level of 'community'. I tried to set the level from partner to community as follows:

 # esxcli software acceptance set --level=CommunitySupported

Which resulted in:

[AcceptanceConfigError]
Unable to set acceptance level of community due to installed VIBs virtuallyGhetto_bootbank_ghettoVCB_1.0.0-0.0.0 having a lower acceptance level.
Please refer to the log file for more details.

If I list the installed software, that specific file is listed as:

ghettoVCB   1.0.0-0.0.0    virtuallyGhetto  CommunitySupported  2015-10-27

This does imply that the level I'm trying to set is not lower then it need? Digging further, it seems that this was installed by just adding -f to the install command.

How could I lower the acceptance level on this machine? Is there an official method, or at least a known issue with having a bit of software in there that needs a lower setting than the current actual setting?

Interesting is that as far as I could find out, CommunitySupported is the lowest level, so I can't set it even lower: my guess is the fact that it is lower then the current setting makes something go wrong?

Software running is:

VMware ESXi 5.5.0 build-2068190
VMware ESXi 5.5.0 Update 2

Because on this server I didn't even need that 'ghettoVCB', so I just uninstalled it; lowering the acceptance worked perfectly after that. But this is obviously a workaround not usefull in all cases, so i'm interested in a real solution // what i should have done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.