1

I'm having an issue. I've set up a third party SSO with my office365 account. The third party SSO authenticates with my on-premesis Active Directory. The only difference between using an ADFS on premesis SSO and this one is that this one is located "in the cloud"...but i digress.

Anyways, I ran DirSync and enabled password sync between office365 and my AD. This was successful and is currently working.

Then I "federated" the domain to get it to work with SSO.

I connected to my office365 subscription using windows Azure AD Powershell (connect msol). I then successfully federated the domain.

To create the settings, I used the powershell command, “Set-MsolDomainAuthentication” and added some parameters afterwards to set up the service.

Due to a typographical error on my part, I incorrectly set the “IssuerUri" “LogOffUri" “PassiveLogOnUri” incorrectly.

I went back into Azure AD powershell and attempted to correct these parameters using the "Set-MsolDomainAuthentication” command. However, they WILL NOT update to the new values! Powershell “accepts” the command, but I see no front-end change of these url’s.

Obviously, the issue is, when trying to sign into microsoft online, it redirects me to an incorrect url, so i cant "sign on" using SSO. I still have backend access via the admin credentials.

Any help is appreciated!

1

I know its too late,but thought of updating so that it will help someone else

To remove federation apply below command.

a. If the domain is federated with ADFS:

Set-MsolADFSContext -Computer your_ADFS_server_computer_name

Convert-MsolDomainToStandard -DomainName yourdomain.com -SkipUserConversion:$true -PasswordFile C:\userpasswords.txt

Set-MsolDomainAuthentication -Authentication Managed -DomainName yourdomain.com

b.If the domain is federated with another IdP:

Set-MsolDomainAuthentication -Authentication Managed -DomainName xxx.com (your domain)

Further reference

https://support.onelogin.com/hc/en-us/articles/203748160-Disabling-ADFS-federation-to-enable-OneLogin-SSO-with-Office-365

0

You have to remove the federation completely and reconfigure it. Look at the Convert-MsolDomainToStandard command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.