0

On a fresh installation, on my local SQL server instance, using SQL Server Management Studio, I can login with my Windows authentication, but not with my sa user. In both cases, I'm using (local) as my Server name. The error is the following:

A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)
  • The password is correct, since I've change it.
  • I did reboot my computer since the installation of SQL Server.
  • The SQL Server Agent is not running; I believe it's only for the jobs.
  • The SQL Server Browser is not running; I believe it's only for remote connections, and it's not running as well on another computer where I don't experience the problem.
  • In the SQL Server Configuration Manager, the SQL Native CLient (both 32 and 64 bits) enables Shared Memory, TCP/IP and Named Pipes (I didn't changed anything on these settings)
  • In the SQL Server Configuration Manager, the SQL Server Network Configuration only allows Shared Memory and TCP/IP; Named Pipes and VIA are disabled (I didn't changed anything on these settings)
  • In the SQL Server Configuration Manager, trying to activate the Named Pipes for the Network Configuration (and to restart the MSSQLSERVER service) didn't fixed the problem (I didn't reboot for this change).
  • I've tried to change the connextion Server name from (local) to 192.168.x.x or to MY-COMPUTER-NETWORK-NAME without any success.

I'm using Microsoft SQL Server 2008 R2 (SP1) - 10.50.2500.0 (X64) Jun 17 2011 00:54:03 Copyright (c) Microsoft Corporation Standard Edition (64-bit) on Windows NT 6.1 <X64> (Build 7601: Service Pack 1).

Any ideas where to look or how to fix it?

2

After double-checking the parameters I choose when reinstalling, I realized that Mixed-mode wasn't checked, only Windows authentication mode.

Following the instructions to this link fixed my problem: https://msdn.microsoft.com/en-us/library/ms188670.aspx

(I'm quite impressed by the clarity of the Microsoft error message in this simple case)

| improve this answer | |
0

I faced this issue when I tried to a working SQL Server in my local environment. in my case the number of user connections was reset to 1. you need to reset it 0 sp_configure ‘user connections’, 0. If you need the complete script please visit this URL: https://www.windowstechupdates.com/microsoft-sql-server-error-233-no-process-is-on-the-other-end-of-the-pipe/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.