2

(I am using a UFS file system on a Solaris server. I have root privileges on the machine, but not on the machine that contains the disc in question.)

I am receiving a "Disc quota exceeded" error when I try to do anything (write to a file, delete a file, etc.). The system has been poorly managed, and a lot of old backup files are just hanging out; I can clean them up, but I am having trouble even creating some breathing room.

Both my disc space and inode count are full:

#> df -hk
Filesystem          1K-blocks     Used Available Use% Mounted on
server.com:/storage  52231997 52231997         0 100% /opt/files

#> df -i
Filesystem             INodes    IUsed   IFree IUse% Mounted on
server.com:/storage    169224   169224       0  100% /opt/files

All of the solutions I have found involve writing /dev/null or "" to a file to zero out its size, then deleting the file. However, neither of these solutions works:

#> ls -l September22014.tgz
-rw-r--r-- 1 userA groupA 283443184 Sep  2  2014 September22014.tgz

#> cp /dev/null September22014.tgz
cp: cannot create regular file `September22014.tgz': Disc quota exceeded

#> echo "" > September22014.tgz
bash: September22014.tgz: Disc quota exceeded

#> > September22014.tgz
bash: September22014.tgz: Disc quota exceeded
  • Try > September22014.tgz the echo isn't needed to truncate the file. – user9517 supports GoFundMonica Jan 9 '16 at 22:50
  • @lain Thank you. Same thing, though. I added that solution to the list. – Kittsil Jan 9 '16 at 22:55
  • 1
    Sounds like you'll have to get the server administrator to delete something locally on the server. – kasperd Jan 9 '16 at 22:58
  • 1
    OK, so what happened when you tried deleting a file? You forgot that display. – Michael Hampton Jan 9 '16 at 23:26
  • 1
    Having both the entire space and all inodes used up is very unlikely. The problem here seems to be exceeded quota on the NFS server, which is even indicated by one of the messages cited. Is that possible that quota settings changed recently? You will have to contact server's admin or access it by other means (SSH?) with the privileges allowing you to delete some of the files. – sam_pan_mariusz Jan 10 '16 at 17:17
1

First, you didn't note the version of Solaris being used, or what the NFS server/device is (if known).

Instead of trying to null out the file, you would have wanted to remove it.

For future reference, with UFS, you could run out of inodes despite there being "free" space left. The only way to resolve is to re newfs it with options for more inodes, or use a FS w/out that limitation. ie: ZFS on newer releases of Solaris.

  • with UFS, you could run out of inodes despite there being "free" space left. That's not just a Solaris/UFS problem. I recently witnessed a coworker's Gnome desktop go berserk on a Centos machine and use up all of /tmp's inodes with empty files. It's amazing how much of an "enterprise" OS falls on its face when it can't use /tmp... – Andrew Henle May 27 '18 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.