0

We have a computer running ubuntu with name nameA. The DNS server runs on ubuntu as well, while all other computers are windows 7.

If I ping the computer from another ubuntu, all fine, the name is resolved correctly.

$ nslookup nameA
Server:     127.0.1.1
Address:    127.0.1.1#53

Name:   nameA.domainname
Address: 192.168.30.30

If I do the same on a windows 7 machine I get Domain non-existant, while it works if I append the domainname: nslookup nameA.domainname. If I nslookup other machines it doesn't find them without the domain name appended, but it is able to ping them with or without the domain name.

The names are listed as nameA.domainname nameB.domainname ... on the DNS.

  • The server isn't on the localhost, it's on .30.230. The ubuntu is resolving the name itself on the first nslookup, why can't windows do it as well? – quimnuss Jan 11 '16 at 8:35
  • 1
    Have you specified a DNS suffix for the Network Connection on the Windows 7 machine. (I haven't for mine and I have the same issues; they went away if I specified that doman name in Append these DNS suffixes box of the Advanced TCP/IP Settings dialog.) – darklion Jan 11 '16 at 8:53
  • No I haven't because if windows is capable of find the other windows machines with ping, why shouldn't it find the ubuntu one as well? If I don't find the culprit, I will do it, but there are many machines to be set, then. Or probably duplicating the dns entry without the domain works too. – quimnuss Jan 11 '16 at 9:00
  • Windows machines by default only look for machines within their own (AD) domain or workgroup. It could only be resolved if your Windows machines are in an AD domain and that name is the same as the one configured on the Ubuntu machine. If it's not, you need to apply the fix as suggested by @darklion – Oldskool Jan 11 '16 at 12:27
  • @Oldskool Yep, that was it, as soon as I added the samba package and set the domain the ping worked without explicitly adding the suffix. Consider adding all this info as an answer so I can accept it. – quimnuss Jan 11 '16 at 12:52
1

Windows machines by default only look for machines within their own (Active Directory) domain or workgroup. It could only be resolved if your Windows machines are in an AD domain and that name is the same as the one configured on the Ubuntu machine.

If it's not in the same domain, you need to add the "custom domain" to the list of domains that Windows looks in for autocompleting short hostnames. You can set the domain in the Append these DNS suffixes box of the Advanced TCP/IP Settings dialog. You can also achieve the same using command line tools, as described in this superuser.com answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.