3

I am trying to get the cron daemon to start on reboot on an instance of Amazon Linux (Linux version 3.14.57-34.46.amzn1.x86_64). I have run:

$ sudo chkconfig crond on

If I run:

$ chkconfig --list crond

I get:

crond    0:off   1:off   2:on    3:on    4:on    5:on    6:on

The system's default run level is 3.

Starting/stopping crond manually works fine, and the commands in my crontab are executed.

$ sudo service crond <start|stop|restart>

After reboot there are no warning or error logs in /var/log/cron (there are non-error logs once cron is started manually) or /var/log/messages. Am I missing something? How can I debug this?

1

I met similar situation. but finally I solved it.

I tried 2 way.

(1) all requires update
sudo yum update

(2) wait login to finish all initialization on AmazonLinux

| improve this answer | |
  • Thanks for your response, but I have tried updating and crond is still stopped on reboot – sohelpme Mar 8 '16 at 19:16
0

In case anyone has a similar problem, here's what the issue was: nginx was also set to start on boot and had a password-protected SSL certificate key. After the passphrase was removed from the key, crond started on reboot.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.