1

Im trying to get KDE running on an Oracle Linux box which runs on vmWare (VMware vCloud Director / ESX)

After installing X and KDE i got the following error:

# startx
[...]
VMware: No 3D enabled (0, Success).

Then i tried to configure:

# Xorg -configure
[...]
No devices to configure.  Configuration failed.

Log:

# cat /var/log/Xorg.0.log
[...]
[   611.117] (II) vmware: driver for VMware SVGA: vmware0405, vmware0710
[   611.117] (WW) Falling back to old probe method for dummy
[   611.117] (WW) Falling back to old probe method for vesa
[   611.117] (WW) Falling back to old probe method for modesetting
[   611.117] (WW) Falling back to old probe method for fbdev
[   611.117] No devices to configure.  Configuration failed.

My Card:

# lspci
[...]
00:0f.0 VGA compatible controller: VMware SVGA II Adapter

I wrote a minimalistic Xorg.conf file myself (old times...)

# cat /etc/X11/xorg.conf.d/10-screen.conf
Section "Device"
    Identifier     "Frame Buffer"
    Driver         "vmware"
EndSection

But i got the same result: VMware: No 3D enable

I am out of ideas.

2

Make sure 3D support is enabled in the video card options of your virtual machine:

enter image description here

It may be possible that the option is greyed out, even though the machine is powered off (you can't change the option while the VM is running or suspended).

In that case you can enable it by editing the .vmx file of the VM, as described in this knowledge base article.

  • Download the .vmx file
  • Open it in a text editor
  • Add this line:
mks.enable3d = TRUE

(Or edit the line, if it already exists and is set to FALSE.)

  • Upload the file back on the datastore of your ESXi server
  • Run the following command on the server console to reload the VM configuration
vim-cmd vmsvc/reload 

(Alternatively you can remove the VM from the inventory and re-add it)

Afterwards the option is enabled and available for your guest system, provided the necessary drivers are installed and active.

1

You need to install VmWare Tools: yum install open-vm-tools. VGA driver is part of them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.