2

I have setup two Scheduled Tasks in the ColdFusion Administrator. When I attempt to run them manually (using the "play" button in the Administrator), the page responds with:

This scheduled task was completed successfully.

However, the task has not run.

The coldfusion-out.log file has the following entries:

Jan 12, 2016 10:05:23 AM Information [DefaultQuartzScheduler_Worker-6] - Task default.Maintenance - Refresh SOLR Collection triggered.
Jan 12, 2016 10:05:23 AM Information [DefaultQuartzScheduler_Worker-6] - Starting HTTP request {URL='https://example.com/tasks/solr/', method='get'}
Jan 12, 2016 10:05:45 AM Error [DefaultQuartzScheduler_Worker-6] - Connection Failure: Status code unavailable

I am able to run the same URL in a browser with no issue - the script runs correctly.

I have imported the SSL certificate into the JRE keystore, so I don't think that's the issue.

Any idea what is going on here?

  • Are you sure you imported the certificate into the correct Java keystore (the JVM that ColdFusion is running under)? Did you restart ColdFusion after importing the certificate? Is there an authentication challenge (username/password) to reach that URL? – Miguel-F Jan 12 '16 at 16:29
  • @Miguel-F Thank you for your response! I ran a -list command on the keystore and I can see the SSL certificate that I imported in the list. I have restarted ColdFusion several times since. There is no authentication challenge to reach the URL. If there was, I would expect a 403 response and an error, but the log doesn't record any Status Code. Perhaps I will try importing the certificate again... – Eric Belair Jan 12 '16 at 20:18
  • @Miguel-F Just to confirm, I should be importing the certificate to the keystore in lib\security\cacerts in the JRE that ColdFusion is using, right? So, if I have configure ColdFusion to user a different JRE, installed in "C:\Program Files\Java", I would import to the keystore in that same JRE. – Eric Belair Jan 13 '16 at 19:25
  • 1
    Yes that is correct. You must install the certificate within the JRE that ColdFusion is using. Just to clarify further, if you have ColdFusion configured to use C:\Program Files\Java then you would import the certificate to the keystore located under that same folder C:\Program Files\Java. And you must restart CF after importing. – Miguel-F Jan 13 '16 at 21:28
3

I was able to fix this by deleting the existing certificate entry from the keystore, then importing the correct certificate. I had originally imported the private certificate (.crt). So, I had to save a copy of the public certificate in DER format and import it, and the scheduled tasks worked again.

  • Glad you got it working. Nice job! – Miguel-F Jan 13 '16 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.