5

I am using Amazon CloudFormation to create a Stack with EC2 and RDS (Postgres 9.4.4, 5gb, db.m1.small). The RDS instance initiates a backup as soon as it starts.

How can I stop RDS from backing it up at startup?

Here is the Postgres log:

2016-01-12 22:23:31 UTC::@:[2435]:LOG: database system is ready to accept connections
2016-01-12 22:23:31 UTC::@:[2448]:LOG: autovacuum launcher started
2016-01-12 22:23:34 UTC::@:[2445]:LOG: checkpoint starting: immediate force wait flush-all
2016-01-12 22:23:34 UTC::@:[2445]:LOG: checkpoint complete: wrote 23 buffers (0.0%); 0 transaction log file(s) added, 0 removed, 0 recycled; write=0.005 s, sync=0.011 s, total=0.051 s; sync files=20, longest=0.011 s, average=0.000 s
2016-01-12 22:23:35 UTC::@:[2445]:LOG: checkpoint starting: immediate force wait
2016-01-12 22:23:35 UTC::@:[2445]:LOG: checkpoint complete: wrote 0 buffers (0.0%); 0 transaction log file(s) added, 0 removed, 0 recycled; write=0.001 s, sync=0.000 s, total=0.005 s; sync files=0, longest=0.000 s, average=0.000 s
2016-01-12 22:25:20 UTC::@:[2445]:LOG: checkpoint starting: force wait
2016-01-12 22:25:24 UTC::@:[2445]:LOG: checkpoint complete: wrote 32 buffers (0.1%); 0 transaction log file(s) added, 0 removed, 0 recycled; write=3.133 s, sync=0.015 s, total=3.161 s; sync files=27, longest=0.015 s, average=0.000 s
2016-01-12 22:30:20 UTC::@:[2445]:LOG: checkpoint starting: time
2016-01-12 22:30:20 UTC::@:[2445]:LOG: checkpoint complete: wrote 1 buffers (0.0%); 0 transaction log file(s) added, 0 removed, 0 recycled; write=0.001 s, sync=0.004 s, total=0.018 s; sync files=1, longest=0.004 s, average=0.004 s
----------------------- END OF LOG ----------------------

The "Alarms and Recent Events" panel on the web GUI say:

time (utc-5)    event
Jan 12 5:29 PM
Finished DB Instance backup
Jan 12 5:25 PM
Backing up DB instance
Jan 12 5:24 PM
DB instance created
  • This question has an answer at StackOverflow – Leon Feb 7 '19 at 5:49
3

Set up your maintenance and backup window in the RDS instance control panel. Some information is available here.

This "backup on creation" behavior isn't documented anywhere I can see. It may be automatic and not able to be changed.

Why are you creating so many databases or stopping / starting database so often that it matters? Some context could make it easier to help you. I created my RDS database once, it's backed up nightly in my backup window.

| improve this answer | |
  • Does this mean I have to disable backup on creation? – szxk Feb 18 '16 at 16:55
  • I think you can change your backup window any time you want. I don't know why you'd have to disable backup on creation. – Tim Feb 18 '16 at 18:08
  • The only options I see on the page you linked are for "Disabling Automatic Backups" and "Enable Automatic Backups". Ctrl-F "window" doesn't even find anything. What do you mean maintenance and backup window? – szxk Feb 19 '16 at 19:09
  • Link and text updated (5 seconds on Google). – Tim Feb 19 '16 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.