0

I am attempting to upgrade my vCenter Server Appliance installation from 5.5 to 6.0. I am receiving the following errors when attempting to preform the upgrade.

Cannot upgrade vCenter Server Appliance with an external Platform Services Controller because the Platform Services Controller is deployed as part of an embedded deployment model. Upgrade the vCenter Server Appliance instance to vCenter Server Appliance with an embedded Platform Services Controller

Upgrade the vCenter Server Appliance instance to vCenter Server Appliance with an embedded Platform Services Controller

I have been searching high and low on information on how to add the Embedded Platform Services Controller to my current vCenter installation but have been striking out.

Is anyone able to point me in the right direction on this?

0

After contacting VMware we found out that the installation of 5.5 U3b I was on was not compatible for an upgrade to 6.0 with out a modification because support for SSLv3 protocol is disabled by default on on 5.5 U3b version.

There was a work around for this, but VMware did not recommend it, or support it. If anyone is interested in what this work around is I have added it.


On vCenter Server Appliance:

  1. Open file /usr/lib/vmware-sso/conf/server.xml in the machine where vCenter 5.5 Update 3b is installed.
  2. Create a backup copy of the file.
  3. Remove the tag sslEnabledProtocols="TLSv1,TLSv1.1,TLSv1.2" from the below line in the server.xml file:
  4. Restart the vmware-stsd service using the following command: service vmware-stsd restart
0

my solution was to update the vcsa to the latest version. For me it was to 5.5.0 Update 3d and then I didn't get any more the message:

Cannot upgrade vCenter Server Appliance with an external Platform Services Controller because the Platform Services Controller is deployed as part of an embedded deployment model...

0

Litzner, Just had the same problem updating from 5.5 to 6.0 Build 5318200. The error is a bit cryptic, but you need to select the other installation choice. Sorry that I don't have the exact wording, but it's obvious once you're in the drop-down box selecting the choice.

Instead of telling it to upgrade vCenter, select the other option relating to the appliance/database. It will perform the entire upgrade for the stand-alone vCenter server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.