0

I enabled the module Advanced CSS/JS Aggregation (advagg) 7.x-2.17 on Drupal 7 and now in my admin page admin/config/development/performance/advagg/font I see a warning:

Trying to get property of non-object in advagg_font_admin_settings_form() (line 31 of .../modules/advagg/advagg_font/advagg_font.admin.inc).

What is going on? Did I configure the module incorrectly?

My webserver is Apache 2.2.15 (CentOS).

0

The line in question is:

6 => t('Externally load the latest from github (version: @version)', array('@version' => $package->version)),

And the object is created at the beginning of the file:

$package = drupal_http_request('https://cdn.rawgit.com/bramstein/fontfaceobserver/master/package.json', array('timeout' => 7));

Given you are still running Apache 2.2, you probably don't have the latest CentOS release. It might be that your root certificates are outdated, or your HTTPS handling is broken in other ways: this happens often to old software, since websites switched to more secure encryption.

As long as you can't upgrade or fix your server, switching https:// to http:// is the workaround.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.