0

I'm trying to install postgis with aptitude on Ubuntu 15.10 and is having problems with virtual packages that prevent the installation.

me@laptop:~$ sudo aptitude install postgis
The following NEW packages will be installed:
  libgdal1{ab} libgeos-3.3.3{a} libgeos-c1{a} libgif4{a} libhdf4-0-alt{a} libjson0{a} liblwgeom-2.1.8{ab} libmysqlclient18{a} libodbc1{a} libogdi3.2{a} odbcinst{a} odbcinst1debian2{a} postgis postgis-doc{a} 
  postgresql-9.4-postgis-2.1{ab} 
0 packages upgraded, 15 newly installed, 0 to remove and 5 not upgraded.
Need to get 11.9 MB of archives. After unpacking 31.6 MB will be used.
The following packages have unmet dependencies:
 postgresql-9.4-postgis-2.1 : Depends: libproj0 which is a virtual package and is not provided by any available package.

 liblwgeom-2.1.8 : Depends: libproj0 which is a virtual package and is not provided by any available package.

 libgdal1 : Depends: libarmadillo2 (>= 2.4.2) which is a virtual package and is not provided by any available package.

            Depends: libdap11 which is a virtual package and is not provided by any available package.

            Depends: libdapclient3 which is a virtual package and is not provided by any available package.

            Depends: libepsilon0 which is a virtual package and is not provided by any available package.

            Depends: libhdf5-serial-1.8.4 which is a virtual package and is not provided by any available package.
 or
                     libhdf5-1.8.4 which is a virtual package and is not provided by any available package.

            Depends: libnetcdf6 which is a virtual package and is not provided by any available package.

            Depends: libpoppler19 which is a virtual package and is not provided by any available package.

            Depends: libproj0 which is a virtual package and is not provided by any available package.

            Depends: libspatialite3 (>= 2.4.0~rc2) which is a virtual package and is not provided by any available package.

            Depends: libxerces-c28 which is a virtual package and is not provided by any available package.

How do I install the virtual packages such as libproj0, so that I can get postgis setup?

  • 1
    Please show your apt sources.list file(s).. – gf_ Jan 13 '16 at 15:34
  • Only tangentially relevant, but whoever named their package libproj0 should almost certainly not be allowed to write software. – Parthian Shot Jan 13 '16 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.