I am setting up a private DNS server that will only be accessible by my OpenVPN users. OpenVPN is setup on the tun0 interface of my Ubuntu 14 server.

The issue is that I am getting some errors. I am unsure how to resolve them. Also I am unsure if if configured my BIND9 server correctly.

Here is what I get when I test my configs:

named-checkconf:

Nothing...

named-checkzone one.example.com db.one.example.com:

db.one.example.com:17: ignoring out-of-zone data (jeannicolas.com.air.jn) zone one.example.com/IN: loaded serial 3 OK

named-checkzone 8.10.in-addr.arpa /etc/bind/zones/db.10.8:

dns_rdata_fromtext: /etc/bind/zones/db.10.8:6: near eol: unexpected end of input zone 8.10.in-addr.arpa/IN: loading from master file /etc/bind/zones/db.10.8 failed: unexpected end of input zone 8.10.in-addr.arpa/IN: not loaded due to errors.

ifconfig details for OpenVPN:

tun0
Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:10.8.0.1 P-t-P:10.8.0.2 Mask:255.255.255.255 UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1 RX packets:3646 errors:0 dropped:0 overruns:0 frame:0 TX packets:3957 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:100 RX bytes:476530 (476.5 KB) TX bytes:2238555 (2.2 MB)

named.conf.local

zone "one.example.com" {
        type master;
        file "/etc/bind/zones/db.one.example.com"; # zone file path
#       allow-transfer { 10.128.20.12; };         # ns2 private IP address - secondary
};

zone "8.10.in-addr.arpa" {
        type master;
        file "/etc/bind/zones/db.10.8";  # 10.8.0/24 subnet
#       allow-transfer { 10.128.20.12; };  # ns2 private IP address - secondary
};

zone "jn." {
        type master;
        file "/etc/bind/db.jn";
};

named.conf.options

acl "trusted" {
#       127.0.0.1;
        10.8.0/24;
#       10.8.1.0/24;
};

options {
        directory "/var/cache/bind";

        recursion yes;                 # enables resursive queries
        allow-recursion { trusted; };  # allows recursive queries from "trusted" clients
#       listen-on { 127.0.0.1; };   # ns1 private IP address - listen on private network only
        listen-on { 10.8.0/24 };
        allow-transfer { none; };      # disable zone transfers by default

        forwarders {
                8.8.8.8;
                8.8.4.4;
        };
};

db.10.8

$TTL    604800
@       IN      SOA     one.example.com.        admin.one.example.com. (
                                3       ; Serial
                           604800       ; Refresh
                          2419200       ; Retry
                           604800 )     ; Negative Cache TTL
; name servers
        IN      NS      ns1.one.example.com.

; PTR Records
3.0     IN      PTR     ns1.one.example.com.    ; 10.8.0.3

db.one.example.com

$TTL    604800
@       IN      SOA     ns1.one.example.com. admin.one.example.com. (
                                3       ; Serial
                           604800       ; Refresh
                            86400       ; Retry
                          2419200       ; Expire
                           604800       ; Negative Cache TTL
)
;
; name servers - NS records
        IN      NS      ns1.one.example.com.

; name servers - A records
ns1.one.example.com.            IN      A       10.8.0.3

; 10.8.0.0/16 - A records
jeannicolas.com.air.jn.         IN      A       10.8.0.100

db.jn

;
; BIND data file for TLD ".jn"
;
$TTL    604800
@       IN      SOA     jn.     root.jn. (
                          3             ; Serial
                     604800             ; Refresh
                      86400             ; Retry
                    2419200             ; Expire
                     604800 )           ; Negative Cache TTL
;
@       IN      NS      ns1.jn.
@       IN      A       10.8.0.100
  • Whats the question? The error you've provided is quite clear: The mentioned zone file isn't valid. Either correct it or remove it, if you don't need it. – gf_ Jan 14 '16 at 12:01
up vote 0 down vote accepted

The problem was simple. I did not add a Expire number db.10.8 zone file.

  • do you always need the reverse zone? – thegio Jul 28 '16 at 10:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.