0

I would like to install php53 on centos5.3 (had installed php54 before but removed) I did it as below.

  1. sudo yum remove php php-common php-cli
  2. sudo yum install php53
  3. sudo yum install zabbix-web-mysql

but when i tried last thing, it shows the following error:

Installed: php53.x86_64 0:5.3.3-26.el5_11
Dependency Installed: php53-cli.x86_64 0:5.3.3-26.el5_11 php53-common.x86_64 0:5.3.3-26.el5_11
Complete!
[root@QCacti ~]# sudo yum install zabbix-web-mysql
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel: ftp.jaist.ac.jp
 * atomic: mirrors.neusoft.edu.cn
 * rpmforge: ftp.riken.jp
 * base: centos.mirror.cdnetworks.com
 * updates: centos.mirror.cdnetworks.com
 * extras: centos.mirror.cdnetworks.com
 * addons: centos.mirror.cdnetworks.com
Excluding Packages from CentOS / Red Hat Enterprise Linux 5 - atomicrocketturtle.com
Finished
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package zabbix-web-mysql.x86_64 0:2.4.7-1.el5 set to be updated
--> Processing Dependency: zabbix-web = 2.4.7-1.el5 for package: zabbix-web-mysql
--> Processing Dependency: php-mysql for package: zabbix-web-mysql
--> Running transaction check
---> Package zabbix-web.x86_64 0:2.4.7-1.el5 set to be updated
--> Processing Dependency: php53-bcmath for package: zabbix-web
--> Processing Dependency: php53-gd for package: zabbix-web
--> Processing Dependency: php53-mbstring for package: zabbix-web
--> Processing Dependency: php53-xml for package: zabbix-web
---> Package php-mysql.x86_64 0:5.1.6-45.el5_11 set to be updated
--> Processing Dependency: php-common = 5.1.6-45.el5_11 for package: php-mysql
--> Processing Dependency: php-pdo for package: php-mysql
--> Running transaction check
---> Package php53-xml.x86_64 0:5.3.3-26.el5_11 set to be updated
---> Package php-common.x86_64 0:5.1.6-45.el5_11 set to be updated
---> Package php-pdo.x86_64 0:5.1.6-45.el5_11 set to be updated
---> Package php53-gd.x86_64 0:5.3.3-26.el5_11 set to be updated
---> Package php53-bcmath.x86_64 0:5.3.3-26.el5_11 set to be updated
---> Package php53-mbstring.x86_64 0:5.3.3-26.el5_11 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-26.el5_11.x86_64 from installed has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
  • Please use Markdown and/or the formatting options in the edit menu to properly type-set your posts to improve their readability. Also use cut-and-paste for posting console output and format it as "code" rather than posting screenshots. That improves readability, attracts better answers and allows indexing by search engines, which may help people with similar questions. – HBruijn Jan 14 '16 at 9:40
1

Are you sure you're installing PHP 5.3, not just PHP?

Try following this guide and specify php version during installation like:

yum install php53 php53-cli php53-common php53-gd php53-imap php53-intl php53-mbstring php53-mysql php53-odbc php53-pdo php53-pspell php53-snmp php53-xml php53-xmlrpc

Also, before downgrading, you should remove php54, you sad you had been using:

rpm -qa | grep -i php
yum remove php
yum remove php-cli
yum remove php-pdo
yum remove php-common
yum remove <other php packages>

Now the zabbix-web-mysql you're trying to install has dependency on php5.4. It is not supported with PHP 5.3, however you can try to install it from RPM-package without dependencies:

wget http://repo.zabbix.com/zabbix/2.4/rhel/5/x86_64/zabbix-web-mysql-2.4.7-1.el5.x86_64.rpm
wget http://repo.zabbix.com/zabbix/2.4/rhel/5/x86_64/zabbix-web-2.4.7-1.el5.x86_64.rpm
rpm -ivh --nodeps zabbix-web-2.4.7-1.el5.x86_64.rpm zabbix-web-mysql-2.4.7-1.el5.x86_64.rpm`

But me why would you use CentOS 5.3 which should have been upgraded to 5.11 like 5 years ago?

You should consider installing zabbix on CentOS 7 instead

| improve this answer | |
  • thank you for your help. cause i am using that server for test, i made it like what you said at first. Thank you so much haha – PYO Jan 14 '16 at 10:21
  • well, you should consider upgrading, otherwise you might run into dependency-hell when trying to install anything (probably you're going there right now with zabbix) – Anubioz Jan 14 '16 at 10:24
  • @PYO So has you solved the problem? It's unclear from your message... – Anubioz Jan 14 '16 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.