0

I have installed Windows Server 2012 in a dedicated server, Using a VM I installed Windows 7, Everything is setup for the VM to access the internet. But I am unable to login by remote desktop connection into this VM/Windows 7 from an external network. I want someone to give me some insight about this. I was able to login using RDP using local network. But I want to access the VM using remote desktop connection "mstsc" is there any particular way to route to the VM. My client asked me for this requirement, can a dedicated server be split into many virtual Machines and be given remote desktop access.If this has to be achieved should both the physical server and VM run Windows Server?

0

Start out by checking your firewall settings. If you can RDP from the local network, but not an external one, you are likely being denied connectivity due to a NAT Traversal setting being enabled (this is default on RDP for server 2008+ I believe).

Open Windows Firewall, go to Advanced Settings, go to the Remote Desktop User Mode (TCP), and disable the rule that blocks Edge or NAT traversal.

Furthermore, if it's sitting behind a firewall or NAT router, then you'll have to do some port forwarding to make sure the traffic gets to the machine in question - this depends on how you have the Virtual Switch in Hyper-V enabled (If you're using Hyper-V, but from your question it seems you are...)

  • Hi IceMage, Actually I tried with Hyper-V but it gave some error while configuring for internet on VM, So started using VMware. After that internet problem got solved. Now I have a ques. Let me tell you the dedicated server is having a dedicated IP. So both the physical and VM use the same IP to connect to internet. Imagine the dedicated ip is X.X.X.X and the local ip given to VM is 192.168.X.X if I use mstsc and enter X.X.X.X and give the Username of the VM OS , it must connect in RDP. How to do this? No access to physical router so port forwarding has to have a work around.. please help – Anand N.K. Jan 14 '16 at 18:49
  • The VMware host will need to have a port forward on 3389 to that points your X.X.X.X:3389 > 192.168.x.x:3389 Go to the incomingtcp section here and checkit. vmware.com/support/ws55/doc/ws_net_nat_advanced.html – IceMage Jan 14 '16 at 19:41
  • I tried this using 9997 port forward, but after sometime the port is automatically getting closed. I dont know why. I have added firewall exception it is open for sometime and it is getting closed after sometime automatically. Is there any solution using VPN? – Anand N.K. Jan 14 '16 at 20:18
  • The Edge Traversal setting doesn't do what you think it does and isn't the cause of the problem. Have a read here - blog.boson.com/bid/95501/… – joeqwerty Jan 14 '16 at 20:37
  • Can Anybody share a clear solution for this problem? Is it really possible to access a VM inside a Physical computer via RDP from an external network? does it involve VPN? or is there any straight forward approach by using an ports? – Anand N.K. Jan 14 '16 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.