1

After yum update my apache won't start, I got the following errors:
# service httpd restart Stopping httpd: [FAILED] Starting httpd: httpd: Syntax error on line 13 of /etc/httpd/conf/httpd.conf: Cannot load modules/mod_authn_alias.so into server: /etc/httpd/modules/mod_authn_alias.so: cannot open shared object file: No such file or directory [FAILED]

The line 13 follows:
Header: PidFile run/httpd.pid
# MR -- must be disable here because can not overrite! -- importance for proxy-to-apache
# Listen 80 .... Line 13: LoadModule authn_alias_module modules/mod_authn_alias.so

1
  • "I use Apache 2.2, php54m and PHP-FPM on CentOS 6.7" is a really bad question title.
    – ceejayoz
    Jan 15 '16 at 14:28
4

If you updated from Apache 2.2 to Apache 2.4 then this makes sense. This is because mod_authn_alias doesn't exist anymore. Its functionality resides in the mod_authn_core module. Commenting out the line 13 from /etc/httpd/conf/httpd.conf should do the trick.

5
  • Thanks Mugurel, so I should edit to remove this line 13..?
    – Jerry
    Jan 15 '16 at 14:36
  • Yes, you should add # in front of it, save the file and try and start Apache.
    – Mugurel
    Jan 15 '16 at 14:46
  • I've added # but doesn't help, it always reset by sh /script/cleanup
    – Jerry
    Jan 15 '16 at 15:39
  • What does sh /script/cleanup do? Can you post the script content?
    – Mugurel
    Jan 15 '16 at 16:13
  • There's a command for kloxo that is cleanup for affected software (cleanup process for certain settings). I don't know exactly.. but anyhow when running cleanup, all the index.php will be overwrite by default_index.php. OK never mind, let ignore it...<br /> Let me know how to remove full apache 2.4? Because when running # yum list httpd*; dir -l /etc/yum.repos.d > There are so many show httpd24 such as httpd24u.x86_64, httpd.x86_64, httpd24-apr.x86_64, etc... (I want to use 2.2 only, httpd24 makes some problems on my server). Sorry for many questions.
    – Jerry
    Jan 15 '16 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.