9

I want to automate the upgrade of my 2012 R2 servers from standard to datacenter.

However, there is a prompt at the end of the upgrade waiting for a user response. I have thousands of servers to do and cannot press "Y" at the end of it... any ideas how I can get the prompt to accept "Y" or "N" ?

enter image description here

7
  • I don't know the answer, but what's the reason you want to "upgrade" to datacenter? Are these physical servers? The only difference between standard and datacenter is the amount of virtual guests you're allowed to run... – MichelZ Jan 18 '16 at 13:26
  • Try echo Y | DISM /online…. – Daniel Jan 18 '16 at 13:33
  • 1
    Dude, hide your product key... – Jonathan Kortleven Jan 18 '16 at 13:37
  • 1
    @JonathanKortleven that's the normal KMS setup key. Nothing private there. – TheCleaner Jan 18 '16 at 13:38
  • 2
    OP - have you tried the /quiet option? I'm pretty sure that suppresses the need to tell it to restart. – TheCleaner Jan 18 '16 at 13:39
13
/Quiet

Your servers will reboot automatically if no error occured.

OR

/NoRestart

You won't be prompted to reboot.

Source: MSDN

1
  • thanks a lot for that - the /NoRestart worked. I took a look at the help on the command line but did not look at the documentation. Thanks - that's worked perfectly! – lara400 Jan 18 '16 at 13:50
0

Or force the reboot.. at the end if you 'press' Y it equals to reboot command.. so try creating this kind of script:

shutdown -f -r -t 1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.