3

Our accounting program Exact Accounting automatically sends email statements to customers via Outlook 2013. The statement is comprised of a subject line, an attached pdf, and a blank body. Multiple customers are receiving the winmail.dat file instead of the pdf.

These are the steps I have taken, that have not solved the issue:

  1. Outlook is configured to send HTML.

  2. I have used powershell to set the Exchange Online server to default to TNEF to false.

  3. I have used powershell to add domain objects for 2 different customer domains to default their TNEF to false.

Any suggestions please? Why is the exchange server still encapsulating in this TNEF - what am I missing?

Thanks.

  • 1
    Did you know that you can contact Microsoft tech support by phone if you are a Office 365 customer? They usually call back within the hour and do a great job in helping you out! I had months where I called them once a week and they put so much effort and time in the issue, it's incredible. I am extremely satisifed with their technicians! You should try it. – Daniel Jan 19 '16 at 7:12
  • Daniel I did log tickets with MS support, but after two days of support and them not being able to give me a solution I posted here.. Sometimes MS support is great, others, the guys are vastly inexperienced. I had to explain to the guy which powershell commands to use to test that the TNEF was in fact disabled.. – leo_oz Jan 19 '16 at 7:25
  • I'm sorry to hear that. While you wait for an answer from someone on serverfault, I'd suggest you call Microsoft again and kindly ask the support technician to escalate the problem (That's the magic phrase 😉). In my experience, they maybe want to try one or two more things and then give it to the expert (usually their boss). This may take another day or two, but then the expert should call you back. At least from my experience. – Daniel Jan 19 '16 at 7:41
  • Some other ideas, but from the sound of it, I am not sure if they actually work. You could try to remove the addressee from the Outlook cache and the user's address book. It can happen that the sending format is attached to either if them and overrides the sending format you define in the mail itself. But that wouldn't explain why setting it to text sends it as text. – Daniel Jan 19 '16 at 7:49
  • Thanks Daniel - Unfortunately Plain text was the only way to solve the problem, as these email addresses are from a Database... – leo_oz Jan 22 '16 at 4:56
1

I had to set the email type as Plain Text, this worked. However, the MS documentation clearly states that either HTML or PLAIN text corrects this problem - which apparently is incorrect.

0

This problem exists for decades, as you might have detected by searching the internet for solutions.

I talked to a Microsoft technician and he sent me this:

$UserCredential = Get-Credential
Set-ExecutionPolicy RemoteSigned

$Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid/ -Credential $UserCredential -Authentication Basic -AllowRedirection

Import-PSSession $Session

Set-RemoteDomain Default -TNEFEnabled $false

The important line is the very last one. It's a global setting that disables a sending format that causes the 'winmail.dat' issue for everybody. Or something along those line

The technician assured me that this would have zero side effects, apart from never sending 'winmail.dat' files again. I can confirm, that I have yet to encounter a case where that change does something I was not expecting it to do.

  • 1
    Daniel as per my initial post, I had already tried setting those, and still the same issue. I spoke with MS support and they said that PLAIN text set from outlook is the only way, which it was for me. – leo_oz Jan 19 '16 at 7:22
  • I'm sorry, it's still early in the morning 😴 – Daniel Jan 19 '16 at 7:34
  • Haha no worries :) – leo_oz Jan 22 '16 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.