I'm trying to run ESXi 6 off the Internal USB 2.0 port on a HP Microserver Gen8. No matter what I try it will not make any attempt to boot the internal USB to load the hypervisor.

I installed ESXi 6 with the customised ProLiant HP image (Jan 2016). The steps I took to do this was burn the ISO to a CD and installed it to a 8 GB Transcend while it was plugged into the internal USB slot of the Microserver Gen8. I pulled all SATA drives before installing. The ESXi setup detected the USB drive no problem and installed without an issues. Upon rebooting it doesn't boot from it at all.

I checked my BIOS and all the USB related options appear to be correct:

  • USB Enabled - Enabled
  • USB Boot Support - Enabled
  • Main Boot order - USB DriveKey is set to first priority
  • Internal drives boot priority - USB DriveKey first
  • USB Enumeration - Enabled

To confirm the USB stick is working I pulled it out of the Microserver Gen8 and booted it on a laptop, which booted no problem.

I had the same problem with another USB drive but thought it might just be bad luck for compatibility, however two USB drives doing the same thing seems a little bit suspect.

What am I missing that's preventing the USB drive from booting on the Microserver Gen8 when using the internal port?

  • 2
    I know this doesn't answer your question, but I wouldn't recommend running ESXi off of USB for a non-clustered host. Depending on the RAID controller you have in the system now, you could just create a small 16GB logical drive to house ESXi.
    – ewwhite
    Jan 19, 2016 at 0:48
  • Is there any dependency on HP? I've only seen this once but HP supplied the drive.
    – Jim B
    Jan 19, 2016 at 1:05
  • @ewwhite I guess I could run it off a hard drive, but I was trying to keep thr 4x bays clear for storage. Jan 19, 2016 at 6:24
  • @JimB The USB isn't supplied HP. I also tried using the standard ESXi installer with the same results. There is no logical reason why it doesn't work. Jan 19, 2016 at 6:25
  • @Pandorica Which RAID controller is in your server?
    – ewwhite
    Jan 19, 2016 at 6:40

2 Answers 2


For your actual problem:

Format your USB with MBR and not GPT partitions. That will fix this issue...

Hit Shift-O during installation and add formatwithmbr:

enter image description here

My rant...

See: HP Proliant Microserver Gen8: OS on a Micro SD or USB drive a good idea?

Something many people don't understand about HP ProLiant servers is that HP Smart Array controllers are capable of having multiple "Logical Drives" on the same physical "Array".

This means that you can take a group of disks and separate them into two or more volumes. E.g. 6 x 300GB disks can be 1 x 100GB volume for an operating system and 800GB for data. This is a valuable feature.

So for the example of the particular HP MicroServer in this question, you have a compact server with four drive bays...

enter image description here

The goal is to run VMware ESXi and the OP wants to install it on a USB key. Running VMware on a USB or SD card when you're not operating in a clustered environment with shared storage is a bad idea. Failure of your USB/SD device is a pain to deal with.

ESXi does not require much space, so an easy approach for this server type is to create a 16GB logical drive to house ESXi, then allocate the rest to your VM storage. This way, you have RAID protection for VMware and your data storage without wasting disk space.

  • Thanks for your answer! I fully understand your points and appreciate you taking the time to respond with a comprehensive answer and also identifying a potential issue with my setup. As you can probably gather I'm not an ESXi expert. I will re-attempt the install with MBR rather GPT to confirm the USB will boot. I'll certainly take your comments on board and look at adjusting my original plan. Jan 19, 2016 at 8:48
  • Interestingly formatwithmbr still doesn't fix my USB boot issue. No attempt is made to boot the USB when its housed internally. Jan 19, 2016 at 19:05
  • Although an SD card worked no problem. So I gave up on USB. Jan 20, 2016 at 7:22
  • Yeah? Good deal.
    – ewwhite
    Jan 20, 2016 at 7:23

Resurrecting the thread...

The HP MicroServer Gen8 is incredibly picky about which USB formats and ports it will boot from and in what order.

USB Sticks must be using MBR partitions, not GPT, and must be using a SysLinux-Method of booting, preferably a Fat32 filesystem and of course no sector sizes above 16KB. Also, the 2 USB 3.0 ports (external, blue) cannot be used for booting.

The only tool that repeatably produced USB sticks usable for the HP MicroServer Gen8 was WinSetupFromUSB_1-7_x64 using the options "Linux ISO Grub4Dos" and "SysLinux Bootsector". This results in a boot menu that has a Grub entry for the ISO provided and one SysLinux entry that is non-functional, but required for the MicroServer to accept the stick and show the menu in the first place. This tool could actually format it as NTFS and it was still bootable in the MicroServer.

Fast USB sticks recommended. And patience, since the MicroServer takes 2-3min for each boot attempt and if it fails repeatedly due to its pickyness, it's depleting the mental health of everone around it.

The MicroServer is still extremely complicated to use and it's not recommended IMHO for any group. For SOHO installations, it has a ton of options and stupid little requirements rendering it almost unusable (No booting from on-board SATA port, workaround required. BIOS-MBR only, no UEFI or GPT support, rendering it complicated for most 2016's OS install media - good luck changing a USB stick from GPT to MBR with Windows alone. Typical CPUs delivered with the MicroServer don't have AES-NI, so encrypting HDDs or SSL traffic or SSH file transfers is extremely unusably slow. the iLO-interface constantly on, draws power needlessly in a SOHO setting. iLO-advanced license required to actually use it anyway. BIOS- and firmware updates require a warranty, registration and support contract with HP, too expensive. Using the RAID controller in RAID modes other than mirror, it requires an additional license or a RAID controller that is double the price of the entire server, why? HP-branded RAM required or it will complain. Passive CPU cooler, but a very noisy case fan to make up for it. The list goes on and on. Not recommended.) - and for serious production environments, the puny MicroServer can never satisfy the performance and component redundancy required, with the AES-NI missing, it doesn't even deliver enough power for a SOHO setting.

  • Thanks for this essential information; noticed that it refuses to boot from the USB 3.0 ports, and wanted confirmation. Jul 11, 2018 at 17:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .