0

What is this message and how can I get rid of it?

I am using ELK stack on windows 8. Every thing works just fine but this message which I get whenever I run logstash, buzzes me off.

This is the complete output I get by running logstash on my console:

C:\Users\masoud\logstash-2.1.1\bin>logstash agent -f logstash.conf
io/console not supported; tty will not be manipulated
Settings: Default filter workers: 2
Logstash startup completed

After this message it starts to show the desired output data.

I searched for an answer but the only thing I could find is that it is a warning message (nothing to be worried about). Probably it has something to do with running under windows OS but I am really curious about what exactly it is, why it is happening and how can I fix it?

1

It's a bug in JRuby implementation, probably this one https://github.com/jruby/jruby/issues/1614 . Also sometimes depends on JVM you are using. TTY manipulation usually is about changing terminal settings, e.g. turning off echo output when typing in password.

You may try to upgrade JRuby to 1.7.24 and see if it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.