0

I do keep on getting this error: 503 AUTH command used when not advertised

I have seen this question : exim configuration: 503 AUTH command used when not advertised

The difference is that i do not even have the AUTH option displayed when i telnet to the server.

EHLO example:
Escape character is '^]'.
220 mail.server.com ESMTP Exim 4.80 Wed, 20 Jan 2016 23:41:12 +0000
ehlo maciej
250-mail.server.com Hello maciej [185.83.216.7]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250 HELP
auth
503 AUTH command used when not advertised

HELO example:
Escape character is '^]'.
220 mail.server.com ESMTP Exim 4.80 Wed, 20 Jan 2016 23:42:54 +0000
helo maciej
250 mail.server.com Hello maciej [185.83.216.7]

As per the post and this document: http://www.hep.phy.cam.ac.uk/exim-doc-4.69/html/doc/spec_html/ch40.html#SECTcontrols

I have tried to enable

hosts   = *
control = allow_auth_unadvertised

but either i am doing this in a wrong place or it just does not work. Also yes i have tried google-ing, tried few examples that i have found but neither worked.

What i am trying to achieve is: Connect Outlook (as per title) with my servers exim4. PS. Thunderbird and RainLoop seems to be working fine, its just the Outlook that refuses to work.

Any one know how i can get this working?

0

From what I have seen Outlook is likely defaulting to attempt authentication. This will cause issues if you haven't set up an authentication mechanism. The other clients likely detected that you don't offer or require authentication.

Outlook does offer an option to turn off authentication in its server configuration tabs. It may be difficult to change.

For this kind of client, I require authentication over an encrypted connection. This is made available via startTLS on the submission port (587) as well as the regular SMTP port (25). This may solve your issue.

Some versions of Outlook used an obsolete login dialog. There is an Exim authenticator that offers tje required dialog. You may want to set up a dummy authenticator for testing that always passes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.