1

i have a problem similar to Fixed and dynamic IPs in ISC DHPD lead to double lease

In my DHCP-Log I often receive warnings like

Jan 21 10:20:56 dc2 dhcpd: Dynamic and static leases present for 192.168.1.107.
Jan 21 10:20:56 dc2 dhcpd: Remove host declaration Ares or remove 192.168.1.107
Jan 21 10:20:56 dc2 dhcpd: from the dynamic address pool for 192.168.1.0/24
Jan 21 10:20:56 dc2 dhcpd: DHCPREQUEST for 192.168.1.107 from 00:24:d7:de:60:50 via eth0
Jan 21 10:20:56 dc2 dhcpd: DHCPACK on 192.168.1.107 to 00:24:d7:de:60:50 via eth0

I am a bit confused and cannot imagine, why this errors appear? Yesterday I also had the problem, that one of my computers did't got the IP from the static entry. Instead he got an IP of the dynamic pool.

This is my dhcpd.conf

subnet 192.168.1.0 netmask 255.255.255.0 {

   option domain-name-servers 192.168.1.8;
   option domain-name "x";
   ddns-domainname "x";
   ddns-rev-domainname "in-addr.arpa.";
   option routers 192.168.1.2;
   option broadcast-address 192.168.1.255;
   option domain-search "x";
   option ntp-servers 192.168.1.8;
   option subnet-mask 255.255.255.0;
   option netbios-name-servers 192.168.1.205; #192.168.1.205;

   # Einige Einstellungen fuer WPAD Probleme
   option wpad "\n";
   # Bekannte Geraete
   pool {
        range 192.168.1.1 192.168.1.169;
        deny unknown-clients;
        }
   # Unbekannte Geraete
   pool {
        range 192.168.1.170 192.168.1.199;
        allow unknown-clients;
        }
   # Peripherie
   pool {
        range 192.168.1.200 192.168.1.240;
        deny unknown-clients;
        }
#       default-lease-time 600;
#       max-lease-time 7200;
}
#

# Reserveriungen...
include "/etc/dhcp/reservations.conf";

My intention was that only 192.168.1.170 - 199 is free for the dynamic area. Is the configuration wrong?

Cheers, Lukas

2

The error says it all, you have both static and dynamic lease present for the same ip address range.

In the following you have defined a dynamic lease:

# Bekannte Geraete
   pool {
        range 192.168.1.1 192.168.1.169;
        deny unknown-clients;
        }

Therefore you shouldn't configure static lease from this range anymore. I guess you have static lease configured from that same range here:

"/etc/dhcp/reservations.conf"

To resolve this, change the dynamic pool (Bekannte Geraete) as below or remove it, if you want to reserve it just for static lease only.

# Bekannte Geraete
       pool {
            range 192.168.1.1 192.168.1.169;
            deny all clients;
            }
  • You were right. Than it was apparently the similar solution as posted in the other question. I just mixed up the function of "deny unknow-clients" and "deny all clients". Thanks for clarifying this. – user333163 Jan 21 '16 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.