0

I'm trying to install curl-devel package as a prior step to installation of git 2.x.x:

 yum install curl-devel

But I get many errors like this one:

Error: Package: gcc-c++-4.4.7-4.el6.x86_64 (@base)
           Requires: libstdc++ = 4.4.7-4.el6
           Removing: libstdc++-4.4.7-4.el6.x86_64 (@anaconda-CentOS-201311272149.x86_64/6.5)
               libstdc++ = 4.4.4-15.el6
               libstdc++ = 4.4.7-4.el6
           Updated By: libstdc++-4.4.7-16.el6.x86_64 (base)
               libstdc++ = 4.4.7-16.el6
               libstdc++ = 4.4.4-15.el6
           Removing: libstdc++-4.4.7-11.el6.x86_64 (installed)
               libstdc++ = 4.4.4-15.el6
               libstdc++ = 4.4.7-11.el6
           Updated By: libstdc++-4.4.7-16.el6.x86_64 (base)
               libstdc++ = 4.4.7-16.el6
               libstdc++ = 4.4.4-15.el6
 You could try using --skip-broken to work around the problem

I don't know what this error is about. Can someone explain and suggest how to fix it?

2
  • Update the system first. – Michael Hampton Jan 21 '16 at 12:27
  • @I have updated the system. I appreciate any other suggestions. – Ehsan88 Jan 21 '16 at 14:20
0

You can use below command -:

yum install curl-devel --skip-broken 

or 

yum install gcc*  

then 

yum install curl-devel
2
  • 1
    yum install gcc* did not work for me – Ehsan88 Jan 21 '16 at 11:03
  • @Ok please try this command -: yum install curl-devel --skip-broken when u try yum install gcc* then what output please send me, – mohit singh Jan 21 '16 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.